iPhone 4 Restore Issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ipodlover77, Aug 2, 2010.

  1. ipodlover77 macrumors 65816

    ipodlover77

    Joined:
    Jan 17, 2009
    #1
    Hey guy. Having a bit of trouble here. My phone is jailbroken and I'm trying to restore to 4.0 (not 4.0.1). My phone is also running 4.0 at the moment so o figured I would run into no problems trying to restore it to the same exact version. After downloading the firmware, I tried to restore it. After a minute or so it gave me an error saying how the firmware isn't eligible with the current build. Any idea what the problem is? Would like to avoid upgrading to 4.0.1
     
  2. cleggster83 macrumors regular

    cleggster83

    Joined:
    May 30, 2010
    Location:
    Bolton, UK
    #2
    For better help try posting this in iPhone hacks. U may find the answer in there or try the dev team website
     
  3. jthomp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
    #3
    Sounds like to me that your "blobs" weren't saved/signed on the cydia server. Therefore, when doing a restore, your only eligible for the latest and greatest firmware (read: 4.0.1) no matter what firmware is currently on your device at this time. Hope that helps, let me know if you have more questions...
     
  4. ipodlover77 thread starter macrumors 65816

    ipodlover77

    Joined:
    Jan 17, 2009
    #4
    darn. i read about that. i was under the impression that that was only for when you were downgrading. i didn't know that it also applies to my case (when the phone is already running 4.0 and you want to restore with 4.0). so im guessing theres no possible way to get my 4.0 back? shoot.
     
  5. jthomp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
    #5
    As far as I understand it, without those blobs being saved, Apple only allows the most current iOS version. So, since you are running 4.0, without your blobs saved, and when they released 4.0.1, your chance to save said blobs is gone by the wayside. At this point, they will only allow you to install/restore to 4.0.1. Now, if and when you install 4.0.1 and jailbreak, you should have the option to save your 4.0.1 blobs before apple releases 4.0.2 or maybe even 4.1. It's like a game of cat and mouse, you just gotta keep up on it...
     

Share This Page