iPhone 4 screen unresponsive while in call

Discussion in 'iPhone Tips, Help and Troubleshooting' started by relienttu, Jan 18, 2011.

  1. relienttu macrumors newbie

    Joined:
    Apr 21, 2010
    #1
    I have the 16gb model, originally purchased on launch day but replaced about a month ago (broken mic on top). For the last week or so, I have had to turn my phone off at the end of a call because the screen is unresponsive. I can't use any numeric menus (I have to hope the company sends rotary callers straight to assistance or I'm screwed) and I can't mess with any menus. When I press an icon, it turns blue but doesn't activate. When I turn the phone off, I have to hold my finger on the slider after I bring it over to get it to actuate.

    I've cleaned the screen and looked into as much as I can but I can't find any fix to this issue. Have any of you had the same problem or am I alone in this? How can I fix it?

    Edit: I forgot to mention that it's on the 4.2.1 OS. If there's any additional information needed, please ask.
     
  2. jetblk328i macrumors 6502

    Joined:
    Apr 20, 2010
    #2
    messed up proximity sensor maybe? might have to take it back to apple again.
     
  3. vachargerfan macrumors regular

    Joined:
    May 28, 2008
    #3
    Have you tried restoring the OS on the phone?
     
  4. relienttu thread starter macrumors newbie

    Joined:
    Apr 21, 2010
    #4
    It might be... I'm not sure. :/ It seems to work fine when I'm in a call and I swipe my finger over it or whatever. It's just that the buttons don't "push".

    I'm going to reset the OS this evening when I'm sure I won't need the phone for anything, but I'm not expecting it to fix anything. I haven't installed an update or any apps in a couple of weeks, so I don't know that it will work. I'll try it anyway, though.
     
  5. relienttu thread starter macrumors newbie

    Joined:
    Apr 21, 2010
    #5
    Restoring the OS did nothing to help me. Am I going to have to return it AGAIN!?
     
  6. jetblk328i macrumors 6502

    Joined:
    Apr 20, 2010
    #6
    must be bad luck... bring it to the store again and see what happens.
     

Share This Page