iphone 4 Stuck in DFU mode , need help

Discussion in 'Jailbreaks and iOS Hacks' started by ansabakhan, Aug 25, 2011.

  1. ansabakhan macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #1
    i am trying to restore my iphone 4 to 4.2.1 and i have my SHSH Blob stored on cydia (i know this from the cydia welcome page i know from 4.0.1 thru latest)

    i have already cooked my iOS file , started Tiny Umbrella TSS server and I do not get 16XX error , every time i get to a complete good restore (verificating iPhone restore shows up) right affter that itunes msg pops up
    that my iPhone is in restore mode (DFU)

    i tried every thing to kick it out of recovery but failed... searching for help i found this link where they are talking about editing host and all .. do i need to do these steps ? i didnt do it .. just started the TSS server and tried restring.. i dont even have my blob saved on my laptop

    http://modmyi.com/forums/3g-s-downg...gs-restore-verification-server-ecid-shsh.html


    do i need to do this ?
    Now you need to edit your etc/hosts:

    1) Open Terminal.app (In Applications -> Utilities) and do: sudo nano /etc/hosts
    2) Comment out 74.208.105.171 gs.apple.com if it exists by pressing the down arrow until you get to it, then by putting a # in front so it looks like: #74.208.105.171 gs.apple.com
    3) Press the down arrow until you get to the bottom (empty) line
    4) Type: 127.0.0.1 gs.apple.com
    5) Press Ctrl + O, press enter, then Ctrl + X.
     
  2. ansabakhan thread starter macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
  3. Dhelsdon, Aug 26, 2011
    Last edited: Aug 26, 2011

    Dhelsdon macrumors 65816

    Dhelsdon

    Joined:
    Feb 5, 2010
    Location:
    Canadian Eh!
    #3
    Open your hosts file again, remove any changes you made then download stock firmware from here and open TU, select everything in the checkboxes UNLESS you rely on a carrier unlock (deselect update baseband). Close TU, and reboot. Open TU, Use TSS server then Shift+Restore from the stock 4.2.1 firmware.

    Edit: This thread might be helpful to you, read it all before you begin!
     
  4. lorax3, Aug 26, 2011
    Last edited: Aug 26, 2011

    lorax3 macrumors regular

    lorax3

    Joined:
    Jun 25, 2007
    #4
    Here is what I did to get my phone finally out of restore. Also just to clarify, if your phone comes back up in iTunes with the picture of the cable and the iTunes logo you are NOT in DFU mode, you are in restore mode. They are different.

    Anyway, here was my method.

    1. My hosts files had both
    74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    Not sure if you need both as I think TU takes care of this for you, but I did and it worked.

    2. Open TinyUmbrella. I selected my iPhone on the left and then clicked "Save SHSH". This wil ping Cydia and see what blobs you have saved. In my general tab I had all boxes checked except "update baseband" and unchecked "request shsh from cydia" once the above step worked and saved my blobs locally.

    3. Start TSS Server.

    4. Open iTunes

    5. Put phone into DFU mode. Hold power and home for 10 seconds, then let go of the power button while still holding the home button. Keep holding the home button until iTunes come up and says your phone is in recovery mode.

    6. Open iTunes and select the firmware you want to use by option/shift clicking restore. Note: I was using stock Apple firmware, in my case it was 4.3.3.

    7. Let iTunes do its thing. Keep your phone plugged into iTunes.

    8. It will likely finish and tell you the phone is in recovery mode. Try to use Tiny Umbrella to "Exit Recovery". It will likely fail.

    9. Put your phone back into DFU mode following step 5.

    10. Use the "Fix Recovery" in Tiny Umbrella. This may fix it, If not keep reading. I got a greenpoison fail at the end, but that's okay for now.

    11. Download RecBoot and try "Exit Recovery" again. If you have gotten this far it may not work, but keep reading!

    12. Download RedSn0w. Select the firmware you are trying to restore to. It will then ask you to put your phone into DFU mode. It will start listing steps, and it gives you about 20 seconds to do it. You can just follow step 5 again if you forgot how to do it. Once RedSn0w detects your iPhone in DFU mode it will take over. If you miss the window to put your phone into DFU mode it is okay, you can try again.

    13. RedSn0w will run for a bit, eventually you should see the Pineappe guy on the screen. The process should freeze after a while. IIRC it freezes on "Moving Applications", but just let it run for a few minutes. You will know when it freezes.

    14. Restart your phone by holding power + home button. Once back up it will be back in recovery mode. (oh no!) Just wait..

    15. Switch back over to TinyUmbrella and click Exit Recovery. This time it will have worked, and put your phone back into normal mode. And your phone will be jailbroken! :)

    It took me several days to figure out how to get out of this recovery loop that TU couldn't fix alone.

    Not sure if ALL these steps are required, but it worked for me, and multiple other phones having this problem.

    Good luck! Happy Jailbreaking!
     
  5. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Good info Lorax. I got stuck in a recovery loop when just trying to update to 4.3.3, & I downloaded FixRecovery & zlib.dll & ran that to get it out of the loop. If all else fails, try that. The write up is here, towards the end of the article:

    http://iclarified.com/entry/index.php?enid=16512
     

Share This Page