iPhone 4 stuck in recovery after 4.3.2 update

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Siemova, Apr 14, 2011.

  1. Siemova, Apr 14, 2011
    Last edited: Apr 14, 2011

    Siemova macrumors member

    Siemova

    Joined:
    Dec 2, 2002
    Location:
    Texas
    #1
    Hi guys,

    When I tried to update from 4.3.1 to 4.3.2 this afternoon, the process stalled and eventually failed, claiming error 9. This happened once before (the 4.3 update, I believe?), but I was able to restore. This time, no such luck. I'm stuck in the recovery loop with, seemingly, no way out.

    Considering that I've never jailbroken or anything of that nature, I'm not sure why I'm having these issues, but here's how I've tried (unsuccessfully) to fix it so far:

    1. Of course, I went through the standard restore process first. When that didn't work, I deleted my .ipsw, had iTunes re-download it, and tried again. (Three times, at that.) No joy.

    2. I uninstalled iTunes and the Mobile .kext's, restarted, and re-installed iTunes. Tried restoring again; got error 1013. Tried yet again; back to error 9.

    3. Tried the process on a different computer. Alas, error 9 is a persistent bugger.

    4. I did some research and decided to give TinyUmbrella a shot. It recognized my device but failed to identify it (question mark under 'Recovery Devices', 'Device Model' INVALID, etc.). A couple of attempts to 'Exit Recovery' did nothing to kick me out of the loop, so I put my phone in DFU mode and tried 'Fix Recovery'. Several tries later, that had also failed me. My iPhone would display some "Unable to find..." errors, eventually restart itself, and be right back in the recovery loop. I suspect the tool needs to be updated in order to play nicely with 4.3.2.

    So... any other ideas? I don't live near an Apple store, so I can't just bring it in. DIY is the way to go... if possible. And the sooner the better! Expert advice would be much appreciated.
     
  2. tokaygecko macrumors newbie

    Joined:
    Apr 14, 2011
    #2
    Similar situation

    I'm in a very similar situation. I have a jailbroken iphone 4 that has been on 4.2.1 since it was jailbroken by Greenpois0n. Yesterday night I decided to update to 4.3.1 and I didn't even notice that 4.3.2 had just come out. After the 4.3.2 update completed the phone rebooted then iTunes gave an error stating that the SIM card inserted was not supported by the phone, to please go to my carrier and get a new SIM. I went to AT&T today for a new SIM and it didn't do anything different, same error message.

    Any time I restore to 4.3.2 through iTunes it gets most of the way through then errors out with error 1013. It is stuck in recovery mode, I cannot get it out with Tiny Umbrella. I've tried downgrading to 4.2.1 and that does the same thing, stuck in recovery loop.
     
  3. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
  4. Siemova thread starter macrumors member

    Siemova

    Joined:
    Dec 2, 2002
    Location:
    Texas
    #4
    Well guys, I have good news and bad news. As a last-ditch effort, I hunted down the 4.3.1 update on Apple's support website (http://appldnld.apple.com/iPhone4/041-0551.20110325.Aw2Dr/iPhone3,1_4.3.1_8G4_Restore.ipsw) and downloaded it last night. Took forever - seems they're throttling download speeds on older firmware versions, because I couldn't get more than ~30Kbps on my 6Mb connection - but it was done when I got up this morning. I tried restoring from that, and voila! The process actually completed.

    So now I have a working phone, which is the good news. The bad news is, the same thing will probably happen next time I try to update. :rolleyes: Unless there's some truly compelling 4.x.x update, I'm thinking I'll just wait for 5.0 and hope for the best!
     
  5. mikeoak29 macrumors newbie

    Joined:
    Apr 17, 2011
    #5
    FixRecovery worked for me

    I had the exact same problem with an iPhone 4. The Apple rep insisted it was a problem with my USB drivers - despite me telling him I had tried several different computers. After hanging up on useless Joe, I stumbled across Fixrecovery and it worked perfectly.

    Download and install Fixrecovery.
    Connect iphone to computer.
    Shut down itunes
    Put iphone in DFU mode and immediatly start Fixrecovery.
    Iphone restarted and was updated to 4.3.2

    http://thefirmwareumbrella.blogspot.com/2011/03/fixrecovery-updated-43-supported.html

    :)
     

Share This Page