iPhone 4 Stuck in Recovery and Will Not Restore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MaxMike, Jul 28, 2011.

  1. MaxMike macrumors 6502

    Joined:
    Dec 6, 2009
    #1
    I just tried to update my iPhone 4, but instead chose to Restore it since I really didn't feel the need to have it jailbroken anymore. I feel like I have tried almost everything (pretty much everything on Apple's troubleshooting page) and I am still SOL. I restored my MacBook Pro's network configuration (running Lion 10.7), edited the hosts file with "# ", etc., and still nothing. Is there anything else to try or am I going to have to bring it to the Genius Bar tomorrow? For the record, its a Verizon iPhone that was running 4.2.8, now trying to restore with 4.2.10. Thanks for any help with this! :confused:
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Make sure you put it into DFU mode (see my sig) to restore it. If it doesn’t work, just keep trying, since it’s all you can do.
     
  3. MaxMike thread starter macrumors 6502

    Joined:
    Dec 6, 2009
    #3
    I actually just left it and instead connected it to my Mac mini, and all went smoothly. I'm glad it's fine, just perplexed why it worked on my older Mac instead of my current gen MBP
     

Share This Page