iPhone iPhone 4 - Stuck in Recovery Loop - Need Help!!

Discussion in 'Jailbreaks and iOS Hacks' started by lpc27, May 6, 2013.

  1. lpc27 macrumors newbie

    Joined:
    May 6, 2013
    #1
    My iphone 4 is stuck in a messed up recovery loop, and I think I may have worsened the problem. Let me explain my situation in full context.

    Got my iphone 8 months ago -> 6 months ago I jailbroke it with sn0wbreeze on a Win7 laptop // tethered jailbreak on 6.0.1 and I use iBooty whenever the phone dies on me -> just last night I decided to try to add Siri to my phone via cydia and a youtube tutorial -> upon following one of the steps, I had to press to reboot my phone. did so, and it got stuck. only the apple will show on my screen

    **the laptop I had used to jailbreak my phone initially was just put into the shop to be repaired, so I have only access to a macbook running OS 10.7.5**

    First I tried downloading and using redsn0w. I tried to just boot the phone, and it would say - Missing Keys.plist for this build

    Second I tried to re-jailbreak it, using redsn0w. I downloaded the iPhone 4 firmware for GSM, and upon applying it to redsn0w's jailbreak (manually selected ipsw) it would say "failed to decrypt kernel"

    Third I downloaded the iPhone 4 firmware for CDMA (which I don't believe is correct.. I feel like I used the GSM firmware when I first jailbroke my phone). Tried to jailbreak it with redsn0w and this firmware, it seemed like it was working, until I got the "Exploit failed" message.

    Fourth I tried redsn0w's Recovery Fix option, and it failed to work as well.

    Fifth I downloaded evasi0n and it didn't recognize my iphone.

    Sixth I tried to restore and update my phone with iTunes. It was working for about 10 minutes, and then failed.

    Seventh After failing to restore with iTunes, I tried to jailbreak with redsn0w again, and this time my phone seemed to respond. I had this image on my phone screen depicting a hard drive with the words "downloading jailbreak data" on it. However, the redsn0w app crashed after "uploading first stage".

    Eighth I downloaded TinyUmbrella, tried to fix the recovery loop I'm stuck in. My iphone screen registered that TU was working, though it read only about 4 lines on it saying that there were items TU could not find. Nothing happened for 20 minutes after that, so I assumed it did not work.



    Now here I am.

    Through writing ^^ that, I considered the possibility that the GSM Firmware I initially downloaded and tried to use with redsn0w was faulty. I confirmed that my phone is a GSM phone, and am now in the process of downloading new firmware to try again.


    Is anyone able to shed some light as to what may have possibly gone wrong? Or if I'm overlooking an easier way to solve this?

    At this point, I don't care if my phone needs to be restored with iTunes. I hardly use the jailbreaking features, and just need my phone to work.

    Thanks, lpc.
     
  2. Dugstar1 macrumors newbie

    Joined:
    May 4, 2013
    #2
    The same thing happened to me .. well sort of .

    I had a tethered jailbreak and rebooted with out the PC and that's when all hell broke loose much like yourself.

    I had to take the phone apart and remove the logic board from the battery and leave it for a while to fully discharge the phone.

    After successfully doing that I managed to get some life into the phone after trying numerous times to get it booted etc and the battery trick worked but in the end I had to go back to 4.3 then 6.1.3 as they are the only blobs I had and managed to restore through Redsnow .

    There is a option with in Redsnow in Extras to restore assuming you have saved blobs and the right IPSW to restore with.

    Bearing in mind this is for a 3GS but I had the very same predicament as yourself and the above method worked for me.
     
  3. lpc27 thread starter macrumors newbie

    Joined:
    May 6, 2013
    #3


    Wow. Sounds like I really screwed my phone up.

    In addition, I should add that I'm not as tech-savy as I'd like to be. I don't have any saved blobs on my Win7 computer, let alone on this Mac that I have to work with. I do have the proper IPSW for 6.0.1, however.

    Is there a way to remotely access a blob that would help me restore my phone? Take it, that I take my phone apart and try the battery trick as you have.
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    OP

    Be specific in what iOS version the phone was at and in each step which IPSW you used and what version of redsn0w you used.
    Also which blobs you have and were they auto saved by Cydia or manually saved?

    Your post is too general to help, please provide more info.
     
  5. Dugstar1 macrumors newbie

    Joined:
    May 4, 2013
    #5
    You could try the "SHSH BLOBS" with in Redsnow ( Redsnow > Exras >SHSH BLOBS )

    As that might fetch them from the Cydia server if you did manage to get them backed up before your Jailbreak last time around. If there are blobs you will need to restore with the corresponding IPSW so say you have 5.1.1 blobs there you need the 5.1.1 IPSW to restore as that's how it restored for me.

    I had blobs saved thankfully as I came from Android based stuff and iOS was all new. :eek:
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    As far as I'm aware, redsn0w only allows you to query cydia for the shsh blobs but doesn't allow you to download them
     
  7. lpc27 thread starter macrumors newbie

    Joined:
    May 6, 2013
    #7
    iOS 6.0.1
    Step 2 - iPhone3,1_6.0.1_10A523_Restore.ipsw (GSM)
    Step 3 - iPhone3,3_6.0.1_10A523_Restore.ipsw (GSM)

    And I don't know what a blob is. I don't know if I would have any, because every time I had backed up my iPhone it was to my personal laptop, which is in for repairs at the moment. I have never backed up nor connected my iPhone (prior to this incident) to the macbook I am presently using.
     
  8. Dugstar1 macrumors newbie

    Joined:
    May 4, 2013
    #8
    I think your right :p

    I'm sure I got them through Tiny Umbrella but after saving them I think as that's the main way to get a phone restored should these sort of things happen.

    Just thinking back to when I tried to restore my phone makes me shudder ..
     
  9. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #9
    I know he is wrong :)

    You can use redsn0w to save existing blobs: the NEW and FETCH commands in Extras/SHSH blobs

    @OP

    Blobs are needed to downgrade or re-restore to non-signed iOS version like 6.0.1
    For the IP4 presently the signed vesion is 6.1.3

    As you did not save your blobs manually the auto saved blobs for 6.0-6.1.2 by Cydia are worthless.

    You are SOL and can only restore to 6.1.3.

    If you need an unlock you can use sn0wbreeze on a windows machine to make custom 6.1.3 IPSW

    If you don't need an unlock you can put the phone in DFU and restore to 6.1.3 in itunes

    You can jailbreak the 6.1.3 with redsn0w but it will be a teteherd JB
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    the FETCH command is only for the A4 devices and under though, no? As far as I'm aware of, it's essentially dumping blobs. The NEW command only allows you to fetch the latest SHSH blob from apple's server

    What I was saying was that redsn0w does not allow you to download SHSH blobs from cydia's server, you only see what blobs cydia has for you using redsn0w. If i'm wrong, please correct me.
     
  11. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #11
    It does use them when restoring through Extras/even more/restore

    Other than that just use Tiny Umbrella or iFaith to save your Cydia saved blobs locally.
     

Share This Page