iPhone iPhone 4 stuck in recovery mode after update

Discussion in 'Jailbreaks and iOS Hacks' started by Toerq, May 15, 2014.

  1. Toerq macrumors newbie

    Joined:
    May 15, 2014
    #1
    Hi,

    I jailbroke my iphone 4 two years ago on iOS 5.0.1. However, I felt that I didnt need the jailbreak anymore so recently, I (stupidly) decided to update to 7.0.6 (or something) through the phone.

    I am now stuck in recovery mode though.
    When I try to update through itunes, it downloads 5.1.1 (GSM) so I guess that is the .ipsw that I should restore to.

    Things I have tried:
    1. Restoring while in the itunes-logo-mode (apple servers did not like this).
    2. Restoring in DFU mode. This gives me error 3194. http://theiphonewiki.com/wiki/ITunes_Errors#Errors_31xx
    3. I have also tried manipulating the hosts file with no luck.
    4. Restoring while running a TSS server on tinyumbrella.

    Is there anything more I can try or is my phone forever dead?
    Thanks in forehand.
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    You can only restore to signed firmwares. Which at the moment would be 7.1.1 for your iPhone 4

    If you want to restore to any version under iOS 7, you need complete and valid blobs. Either use tinyumbrella or iFaith to check if cydia has your iOS 5 blobs

    For iOS 6 blobs, you have to use iFaith to check if they're valid blobs or not

    If cydia doesn't have any of your blobs and you don't have any manually saved ones, you're only option would be to restore to 7.1.1

    Before restoring to 7.1.1, make sure your hosts file doesn't direct you to cydia's servers. Try entering DFU mode and then restore to 7.1.1 if that's what you want
     
  3. Toerq thread starter macrumors newbie

    Joined:
    May 15, 2014
    #3

    When I try to restore to 7.1.1, I get the message "The iphone could not be restored because the firmware file is not compatible".
    Another thing worth mentioning is that when I am in itunes logo mode, its the pre-7.x logo. Combine this with the fact that itunes automatically downloads 5.1.1, so I think that that is the correct OS for me to update to.

    I also tried entering pwned DFU mode with redsn0w.
    This gave me some sort of timeout error: 1602.
    "Restart computer; change computer; reinstall system." is the solution to that according to http://theiphonewiki.com/wiki/ITunes_Errors.
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Make sure you download the correct ipsw for your device. I think there are 3 different versions for the iPhone 4

    Enter normal DFU mode

    Are you trying to load 5.1.1 or 7.1.1? And did you do what I suggested about the blobs?
     
  5. Toerq thread starter macrumors newbie

    Joined:
    May 15, 2014
    #5
    I have used tinyumbrella and I can't find any blobs.
    When I am trying to update to 7.1.1, i get the firware error. When I update to 5.1.1, I dont get the firmware error even though I use the "3,1" (GSM) .ipsw file on both.

    I will try to redownload the 7.1.1 ipsw file anyway, all three of them just to be sure.

    Also, I have tried restoring to 7.1.1 in both "soft DFU" and "pwned DFU". I have not tried normal DFU, might that help me?

    ----------

    Now, my tinyumbrella looks like this:
    http://i.imgur.com/NGeLXAS.png
    Guess that this cant help me tho, this is probably something I created myself a couple of months ago when trying to solve this problem.
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6


    i'm going to assume you don't have any blobs saved on cydia then. that means you can only restore to 7.1.1

    put your device in normal DFU mode. open itunes and it'll detect it in recovery mode

    just click restore. is it downloading the 7.1.1 ipsw?
    if it's downloading the 5.1.1 ipsw, what version of itunes are you using?
     
  7. Toerq thread starter macrumors newbie

    Joined:
    May 15, 2014
    #7

    A 2012 version appearently... Did not think that it mattered though. I will install the newest itunes, attempt to enter "normal DFU", and properly restore it tomorrow.
    Ill post an update here if it doesnt work.

    Thanks for your help so far.
     
  8. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #8

    Old versions of iTunes can't install 7.1.1. Have to upgrade iTunes.
     
  9. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #9
    the version of itunes you have does matter
     
  10. Toerq thread starter macrumors newbie

    Joined:
    May 15, 2014
    #10
    I did try to restore with the .ipsw i downloaded from a ipsw-site, namely "iPhone3,1_7.1.1_11D201_Restore", in the new itunes. The same problem occured (while being in normal dfu this time).
    When I pressed restore without holding down ctrl, itunes started downloading that exact same file. I have a slow connection so it takes 5 hours to download it via itunes, but I have a feeling that that won't work either. We'll see how it turns out.
     

Share This Page