iPhone 4 stuck in recovery mode, error 9?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by michaelfields, Sep 24, 2011.

  1. michaelfields macrumors regular

    Apr 8, 2010
    I tried to restore my iPhone 4 today to 4.3.5 and it got stuck in recovery mode. I've tried restoring, switching usb ports, reinstalling iTunes, brought it to the apple store and they couldn't get it to restore either. It stalls out every time at "restoring iPhone firmware" then cuts off and says error 9. Does anyone know how I can fix it? Apple told me all they can do is give me a new one for 199.

    Also I've tried RecBoot but that didn't work either.
  2. michaelfields thread starter macrumors regular

    Apr 8, 2010
  3. killingvirus macrumors newbie

    Oct 15, 2011
    Try it..
    I tried another solution and it worked for me. I ran redsn0w 0.9.9b5 on a Mac then used the 'recovery bug fix' feature after putting the device into DFU mode. In the middle of the operation and after installing some files into the device I got the device stuck between progress bar and reboot. I hard rebooted the device to put it into recovery mode again using the home and power button then restored to iOS 5. IT WORKED.
  4. user120 macrumors newbie

    Dec 18, 2011
    I had same issue. I tried every things and it did not work. So I left the iphone 4G in recovery mode for a day. Just for the battery drain out. After that I try it work.

Share This Page