iPhone IPhone 4 stuck in recovery mode

Discussion in 'Jailbreaks and iOS Hacks' started by uthaya7, Jun 24, 2012.

  1. uthaya7 macrumors newbie

    May 12, 2012
    Hi Everyone

    I'm don't have much knowledge about JBing. I tried upgrading my jailbroken IPhone 4 to 5.1.1 using redsn0w custom ipsw. But unfortunately ended up in recovery mode :-(
    The phone is detected in recovery mode by iTunes, when i try to install custom made no BB ipsw it shows up error 1604.
    I tried making an another ipsw by stitching my blobs to the custom ipsw and tried installing but receive the same error still.

    I tried on different computers, USBs, iRec, redsn0w etc but i couldn't get the phone out of recovery mode.

    Pls help me!!!
  2. TSX macrumors 68030


    Oct 1, 2008
  3. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    Why a custom IPSW, those are for preserving baseband only. ?
    What baseband is on your phone.
    Also try Redsn0w Recovery fix (or TinyUmbrella which always has worked for me).

    Once you get it out of recovery, go to iClarified.com and follow a tutorial.
  4. uthaya7 thread starter macrumors newbie

    May 12, 2012
    Thanks guys....

    already i tried TU/redsn0w but no use, both failed to kick out of the recovery mode.

    I use custom ipsw coz i depend on hardware unlock for my iPhone.

    My iPhone is now an useless brick since 1 week.
  5. ZCherub macrumors 6502a


    Jul 7, 2010
    GA, USA
    Are you sure you were actually in DFU mode? You should not see the iTunes logo on your phone if you are properly in DFU mode.

    Open RedSn0w and follow the steps to get into Pwnd DFU mode, then CAREFULLY follow the steps - you should see just a black screen and RedSn0w should confirm that you're in Pwnd DFU.

    After that, you can Shift+Restore in iTunes to install your custom iPSW. If that fails, you may try to download another 5.1.1 firmware (perhaps from a different source), and cook a new custom iPSW.
  6. TriJetHero macrumors 601


    Oct 13, 2010
    from the iphone wiki:
    Error 1604
    Device was not pwned (signature checks were not blocked). Custom firmware can't be restored. Can also happen when there's a problem with the IPSW.

    Try again in pwnd-DFU mode using redsn0w
  7. uthaya7 thread starter macrumors newbie

    May 12, 2012
    I'm not in DFU mode guys! When connected with redsn0w it recognizes the mode as recovery mode. When i try recovery fix in redsn0w it ends up with an error "DFU mode failed-You have ended up in recovery mode instead of DFU mode."

    someone please help!!
  8. MNFL macrumors member


    Mar 27, 2012
    been there before...
    system files are corrupt.. iPhone cannot launch because some needed files aren't even there or damaged
    my solution was Restoring in iTunes
  9. labman macrumors 604


    Jun 9, 2009
    Mich near Detroit
    I'm going to suggest that you seek out somebody with more knowledge then yourself on jailbreak/unlocking by that I mean a friend or maybe somebody on craigslist. you have to do things a certain way or else you will loose the preserved baseband also have you tried contacting the carrier to see if they will unlock it. I just think your a little out of your knowledge area here unless you to things correctly your going to mess up big. Yes we can talk you though but we miss a step or you don't fallow a step you are SOL. ;) Also do not update though Itunes as suggested you will loose your baseband. you can also try Ireb and Snowbreeze both for PC only to kick it out.
  10. hasanryaz macrumors newbie

    Aug 15, 2012
    Having the exam same problem!


    I just landed myself in precisely the exam same situation.

    Locked iPhone 4 with 5.0.1 trying to upgrade to 5.1.1 but got stock while iTunes was upgrading and landed in recovery mode. Tiny Umbrella, iReb, Redsn0w.. all have failed to get it out of the recovery mode. Unless it gets out of the recovery mode, I can't get in the DFU.

    Read plenty of blogs.. trying my luck here as well.

    Any help would be much much appreciated!

  11. alexshay32393 macrumors newbie

    Oct 25, 2012
    Here's what I did

    I had the exact same problem after trying to update while saving my BB. I got that same error message that you did. Before you even press next on the screen start doing the process to go into dfu. You will not receive the error message and redsn0w will recognize your in dfu and continue the process from there!
  12. jinx1000 macrumors member

    Jul 12, 2010
    If your phone is out of contract then AT&T will unlock it for free assuming that's your carrier. Also there are tons of cheap imei unlockers out there. There are threads on here suggesting good ones. Also eBay is good because of the feedback available. I got mine done for $13 and it's gotten even cheaper. AT&T again...

Share This Page