iphone 4 stuck on pineapple logo on redsnow tethered reboot

Discussion in 'Jailbreaks and iOS Hacks' started by iloveiphone4, Dec 27, 2010.

  1. iloveiphone4 macrumors member

    Jul 7, 2010
    please help if anyone has any suggestions:

    iphone 4 was updated from 4.1 and 1.59 baseband to 4.2.1 and was able to preserve baseband by pointing to cydia hosts file, and also keeping tinyumbrella open. funny thing is none of my apps were erased or music or anything else, just an incremental update like upgrading windows from service pack 1 to 2.

    installed cydia using redsnow and saw that the cydia installed on reboot but all i saw was a white icon. So tried the second part of process where i check off the boot tethered for now and rebooted my iphone 4 but it is always stuck on pineapple logo with apply busy spinning wheel on top. here is what i tried:

    ran redsnow in compatibility mode both XP sp2 and XP sp3
    ran Redsnow in administrator mode
    ran redsnow in compatibility mode and admin mode
    ran redsnow with affinity set to 1 via the task manager

    none of them work, i have windows 7 64 bit and i am open to any suggestions and i really want cydia to start working.
  2. f4780y macrumors 6502


    Jul 21, 2009
    Troon, Scotland
    If you are seeing the pineapple logo that indicates that the problem is on your phone and not your PC... (the phone is correctly booting into a jailbroken state). You maybe have a corrupted filesystem. This has happened to me once. Afraid the only way to get out of it was to restore and re-jailbreak. It is maybe a symptom of having upgraded rather than restoring. Were you previously jailbroken on 4.1? You might have some 4.2.1 incompatible JB apps on there from 4.1, hence the spinning wheel...
    I honestly wouldn't waste any time on the PC side of things. Sounds as though redsn0w is working fine.
    Hope that helps.
  3. iloveiphone4 thread starter macrumors member

    Jul 7, 2010
    thanks f4780y, will try to restore right now and report back. i dont use cydia much except for unlock and thats all i use cydia, dont even have mobile substrate or sbssettings or any such thing. will try. but it is good to know that i can upgrade and not have to reload all content.
  4. iloveiphone4, Dec 27, 2010
    Last edited: Dec 27, 2010

    iloveiphone4 thread starter macrumors member

    Jul 7, 2010
    tried the restore - and now i realize - i shouldnt have done it. the tiny-umbrella kick out of recovery only works when you upgrade from 4.1 to 4.2.1rather than restore. now my phone is always stuck on the connect to itunes logo since i restored and tiny umbrella kicks me out of recovery mode, but the iphone is once again back in recovery mode. now i hope i can restore back to 4.1 and see if i can still preserve my baseband. will report back what i find out.

    that was some scary moments for the last half hour:

    restored my phone back to 4.1, luckily that worked:

    preserved my basebad doing that, then upgraded back to 4.2.1 and now restoring my iphone from last nights backup. once the restore is completed, i will try to re-jailbreak and see if that works. hopefully now that my phone is literally clean, i can jailbreak and get out of the pineapple logo loop properly, if not wait for a tethered jailbreak i guess, it cant be that far off..

    folks - posting every step i took so that other users can learn from my mis-steps(why did i need all this aggravation - lets say a snow storm outside and nothing to do at home causes geeky guys to do crazy things)

    didnt work, after restoring phone, the tethered jailbreak didnt work for me, i guess it is just not meant to be, i give up on this unless someone has any suggestions. just wait for the un-tethered jailbreak i guess
  5. f4780y macrumors 6502


    Jul 21, 2009
    Troon, Scotland
    Glad you got restored OK.
    Give redsn0w a couple of tries. I've found the limera1n exploit isn't always successful when coming out of DFU mode...
  6. iloveiphone4 thread starter macrumors member

    Jul 7, 2010
    SUCCESS - finally got the tethered jailbreak to work - cant believe the problem, i downloaded the ios 4.2.1 for my iphone 4 when it was first released directly from apple site even though i never upgraded to it. i re-downloaded it today via itunes and this time when i let redsnow choose the file in the iphone software update folder and it worked like magic, tethered jailbreak works and i have cydia installed and now to unlock it...

    man this is crazy who would have thought that a file from apple direct which i downloaded a couple of weeks ago can be different from the one i downloaded today.
  7. INGA macrumors newbie

    Jan 14, 2011
    please help !!

    Hello this is Inga.
    I have iphone 4 .
    I have tied to jailbreak then unlock for to use with a T-Mobile.
    Then after jailbreak i have connect to ituns,and by accident upgraded to 4.2.1.
    Then i have look for help on you tube to downgrade....But after couple steps my phone has stock on recovery mode.Then when i try to restore my phone to factory settings then i get many errors!I saw how you help to other person,maybe you can help me!!!
    P.S.Sorry for my English!!!

Share This Page