Iphone 4 texting?

Discussion in 'iPhone' started by asdad123, Jun 23, 2010.

  1. asdad123 macrumors regular

    Joined:
    Jun 16, 2010
    #1
    Everything works on my phone except texting. Is there some special setting I turned off somehow?
    I activated it like 2 hours ago and I still cant receive/send texts but calling and data works fine.
     
  2. Snowman3459 macrumors 6502a

    Joined:
    Jun 15, 2010
    #2
    Hmm...no there is no option. Have you tried resetting your network? Or even go as far as trying a restore?
     
  3. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
    #3
    Tried resetting network settings, didnt work. Ill try a restore soon.
    Maybe I didnt wait long enough lol
     
  4. Robby C macrumors regular

    Robby C

    Joined:
    Jul 11, 2008
    Location:
    Atlanta
    #4
    Go for the restore if you must, I would just keep waiting. This has happened to me before with a "dumbphone", just had to wait a bit and then it started working. Try getting some sleep tonight and see how it works tomorrow- don't be surprised if it doesn't work though because of how crammed the network is going to be. But yeah restore if you feel you'll have some luck, otherwise keep waiting. It doesn't sound like you're having a hardware issue though, so I wouldn't worry about needing a replacement.
     
  5. CrAkD macrumors 68040

    CrAkD

    Joined:
    Feb 15, 2010
    Location:
    Boston, MA
    #5
    are you a new att member? or just upgrading to the 4? might be a delay if your a new member.
     
  6. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
  7. Streamer macrumors member

    Joined:
    Apr 18, 2008
    #7
    You're not alone. We're not getting texts through either on our 2 iPhone 4's. Mine was an upgrade from 3G and my wife is a line upgrade from a ye olde phone. Voice calls are fine.

    I expect it will all wake up later.... (I hope).
     
  8. Craiger macrumors 6502a

    Craiger

    Joined:
    Jul 11, 2007
    #8
    Texts worked instantly with me upgrading from my 2g. I would call AT&T. It sounds like a network issue and not a hardware issue if I had to guess.
     
  9. Qoo macrumors 6502

    Joined:
    Jun 15, 2010
    Location:
    MI
    #9
    mine works no problem at all.

    Send/Receive working great :D

    Just give it sometime and it should get it to work like normal
     
  10. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
    #10
    Still not working... tried a full restore and nope.
    The annoying thing is that I got a text from ATT saying "Welcome to ATT...." but I cant send texts or receive anything from anyone else.
     
  11. Geekulous macrumors member

    Joined:
    May 31, 2010
    Location:
    Southern California
    #11
    I would give it some time, it took awhile for texts to start showing up when got my 3G (and, like you, I received that initial AT&T text fairly soon after I activated the phone)

    Plus, like people have said before, AT&T's network is probably pretty taxed right now and will probably continue to be throughout the day.

    Good luck!
     
  12. splashnader macrumors 6502a

    splashnader

    Joined:
    Jul 1, 2008
    Location:
    Via Satellite
    #12
    Did you receive a text message from ATT after you activated? Maybe a dumb question, but I did receive one right after activation. Never dawned on me to try and send a text though.
     
  13. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
    #13
    I received the text from them about 3 hours after activating. Still cant text anyone or receive texts from anyone else
     
  14. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
    #14
    So this is pretty irritating. I get a text whenever I dial *639# from AT&T but from noone else :(
     
  15. Streamer macrumors member

    Joined:
    Apr 18, 2008
    #15
    Well, both iPhones received the text from AT&T saying welcome, and still no texts received yet. ! That does surprise me!
     
  16. dreuter macrumors newbie

    Joined:
    Jun 24, 2010
    #16
    this worked for me

    Does it say "subject" in the area you type your sms ? Turn that off in your settings if it does. Worked for me I had the same problem till this morning.
     
  17. asdad123 thread starter macrumors regular

    Joined:
    Jun 16, 2010
    #17
    To anyone else with this problem, I finally got fed up with it and called ATT. They were very helpful. At first they didnt know the problem but they tried taking the messaging plan completely off and then putting it back on. Works perfectly now
     
  18. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #18
    I was going to recommend this. Every upgrade ever on all my phones except my iPhone, they would have to do this. Don't know why but it was a quick fix for me.
     

Share This Page