Iphone 4 Transfer Trauma

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Richdj, Aug 19, 2010.

  1. Richdj macrumors member

    Joined:
    Jan 24, 2008
    #1
    MBP CORE I7
    OSX - 10.6.4
    Itunes 9.2.1
    Iphone 3g 4.0.2

    Hi ok so i finally got my Iphone 4 , been waiting for stock to come in for ages, so today i'm all excited and tried to transfer my old iphone 3G over to my new iPhone 4.
    .
    I backed up my 3G then plugged in my iphone 4 , and did restore from back up.
    My problem is this, ever time i connect the Iphone 4 it gets half way through the back up and then says that a 'back up is not possible because of an error ( no error code given).'

    I reset my computer, and did a fresh back up of the old phone and then erased the new phone and tried again and the same thing happened.

    Once the back up fails, it connects the new phone to itunes and transfers over all my bought apps, but no information such as contacts, messages or any other data from my old phone.

    Its really frustrating have waited ages for this phone and ignored all the signal hassle and still bought one … Now it cant even make it back up to my old phone.
    I though apple stuff was supposed to 'just work' and be easy !!!

    The edge has already been taken off the new phone because of the wait, now its just getting worse … please help somebody.

    My only though regarding this is that the sim in the phone has a different phone number to my old 3G, and the number gets ported tomorrow. Could this be the problem ? ?
     
  2. Richdj thread starter macrumors member

    Joined:
    Jan 24, 2008
    #2
    in relation to this, still having same issue, and dont know what to do, however i noticed in itunes the only back ups showing were todays, and on on the 1st of july, which seems weird since ive backed up loads since then, just checked the back up folder, in libray/application support/mobile sync and found that the back up in july after the long code has a date extension (-20100701-153740) which the new back up does not have. also the files in the old back up are showing with extensinds .mdinfo and .mddata the folder with the latest back up the files have no extension at all. is this normal ?
     
  3. Richdj thread starter macrumors member

    Joined:
    Jan 24, 2008
    #3
    Hey guys, found a soloution to this so thought I'd post for other people to try if they have a similar problem.

    It would appear my back up file was corrupt, and even theo I had done a fresh back up the corruption somhow remained.

    The way i solved it was thus, Go to library/application support/mobile sync.

    Move the current back up files to the desktop

    Plud the old phone back into Itunes, a complete fresh back up will be created, then follow usual restore instructions for the new phone.
    This worked for me and my new phone was restored from the new back up, once i was happy everything was transfered i trashed the old folders from the desktop and now when i connect my new phone it creates it own new back up which is fine .
    Hope its of somehelp to someone somewhere
     

Share This Page