iPhone 4 Unlock issue with 4.0.1

Discussion in 'Jailbreaks and iOS Hacks' started by g33, Dec 17, 2010.

  1. g33 macrumors 6502

    Joined:
    Feb 23, 2008
    Location:
    London, UK
    #1
    I unlocked my IP4 with jailbreakme.com a good few months ago now. I have ultrasnow on it..however, i dont think its working.

    When i insert the SIM it shows no bars of signal or says 'No Service'. At times when in switch it on or insert it i get a message reading INVALID SIM as a pop up.

    Ive tried the sim in a spare phone and it seems to work fine. So im guessing its not unlocked correctly?

    The other thing is i away from home for a few weeks and dont have my computer which i normally backup/sync my iPhone to so if i were to make a custom IPSW i will lose my music, apps etc?! Is that correct?

    Thanks in advance, really could do with using my other SIM!!!
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #2
    Yes, the installation of the ipsw will not let you keep your old data.
    You're going to have to decide which is more important: your unlock or your music, address book, etc. You can get your apps back again; you redownload through the app store.
    Are you sure you haven't damaged the SIM card? If your unlock has been working before, that doesn't sound like an issue with the unlock--unless you installed a bad jb program or updated the baseband.
     
  3. g33 thread starter macrumors 6502

    Joined:
    Feb 23, 2008
    Location:
    London, UK
    #3
    Nope, havent damaged the sim. It was a new replacement from the shop - they had the to custom cut it to be a micro sized one. ive got an adapter so i tried it in a spare phone...

    losing my contacts/phonebook will be an issue. music etc i can live with as i can resync at a later stage.

    ive never tried the unlock since i jailbroke so cant comment on if it worked before. theres no other option to unlock it without losing my contacts? backup onto two machines?
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
    What is your iPhone 4's baseband? If you're in the U.S. make sure you have "3G" off.
     

Share This Page