iPhone 4 update after jailbreak problems

Discussion in 'Jailbreaks and iOS Hacks' started by joshuakrey, Jun 6, 2011.

  1. joshuakrey macrumors member

    Jul 2, 2010
    Hey all. I had my iPhone 4 jailbroken (I think it was greenpois0n) and it has been running slow so I was just going to update to the newest firmware and not worry about a jailbreak right now. I plugged my phone in, downloaded the firmware and started the install. My phone had the Apple logo and the white bar. The white bar went a little over half way and sat there for a long time and didn't move. I tried to stop it and now my phone is stuck on a screen that says connect to iTunes and nothing happens.

    I tried to plug it back in and iTunes told me it found a phone but needed to restore and upgrade. So I tried that and again the same thing happened.

    I need my phone for work and I am lost on what to do to bring it back to life. Any and all help will be greatly appreciated.
  2. SuitcaseB macrumors newbie

    Jun 23, 2010
    Have you tried plugging it into iTunes, holding down the home and power button for 10 secs then letting go of the power button- should put it in restore mode and you should be able to restore then...
  3. gngan macrumors 68000


    Jan 1, 2009
    Just like above. Try to restore it through dfu mode. If you don't know what it is then search iphone dfu mode

Share This Page