iPhone 4 upgraded to iOS 5.1 and lost WIFI

Discussion in 'iOS 5 and earlier' started by apple.net, Mar 8, 2012.

  1. apple.net macrumors member

    Joined:
    Jan 15, 2010
    #1
    I upgraded my iPhone 4 from 5.0.1 to 5.1 last night and then I cannot connect to the wifi in my house. Anyone else has this problem?
     
  2. rosalindavenue macrumors 6502a

    rosalindavenue

    Joined:
    Dec 13, 2003
    Location:
    Virginia, USA
    #2
    After I upgraded my iphone 4 upgraded to 5.1 it is dropping the wifi connection in my office. First time it made me put a password in. It let me manually reconnect without a password the second time.
     
  3. kiwisteve macrumors newbie

    Joined:
    Jun 23, 2010
    #3
    Same problem here with a 3GS. Have rebooted the phone, "forgot" the network, and reset all network settings but it will not reconnect to the wifi network it was connected to prior to the update.

    Also, my personal 3GS running 5.0.1 is sitting next to it happily connected to the same wifi network.
     
  4. white4s macrumors 65816

    Joined:
    Nov 15, 2011
    Location:
    New Jersey
    #4
    did you reset the connection and restart the connection?
     
  5. kiwisteve macrumors newbie

    Joined:
    Jun 23, 2010
    #5
    Ok, well that was weird... left the phone sitting for a while and when I came back to it it had connected. Now working fine. Pretty odd that the second phone remained connected and working the whole time though.
     
  6. apollo1444 macrumors 65816

    Joined:
    Jul 22, 2011
    Location:
    mexico
  7. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #7
    No issues here, but this isn't the first post I've seen reporting wifi issues.
     
  8. bobbyjames macrumors newbie

    Joined:
    Feb 20, 2012
    Location:
    Lowestoft, UK
    #8
    I'm also having issues in my office, the WiFi keeps dropping and re-connecting. sometimes it won't reconnect and when you manually tell it to join the network it says "unable to join network". I've never had this problem until 5.1.
     
  9. Gage macrumors regular

    Joined:
    Oct 12, 2011
    #9
    My wife's 4s had this problem start a few weeks ago. We're hoping the update will fix the problem on her phone.
     
  10. apple.net thread starter macrumors member

    Joined:
    Jan 15, 2010
    #10
    Problem resolved after resetting network settings on iphone and restarting the modem/router. After that I upgraded both iPod Touch and iPad 2 without any issues.
     
  11. ddehr026 macrumors 6502

    Joined:
    May 1, 2010
    #11
    updated both of our iphone 4 to 5.1 and neither will connect to wifi in the apt. Add me to the list...
     
  12. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #12
    I've been hotel hopping in New York since updating to 5.1 and my verizon 4s keeps dropping wifi - sometimes reconnecting on its own and sometimes not. Never seen the problem prior to 5.1
     
  13. TreyCox macrumors regular

    Joined:
    Jan 6, 2012
    Location:
    Swainsboro, Ga
    #13
    My iPhone 4 has had no problems since the update. It works like a charm. Same thing with the ipad 2.
     
  14. MasterHowl macrumors 65816

    MasterHowl

    Joined:
    Oct 3, 2010
    Location:
    North of England
    #14
    Since upgrading to iOS 5.1, my iPhone 4S is forever disconnecting from my university's wifi connection... very annoying!
     
  15. wc3sam macrumors newbie

    Joined:
    May 25, 2009
    Location:
    baltimore
    #15
    ios 5.1 kills wifi thinking to make phone carriers more money on data

    i also am having problems with wifi what did apple do my phone worked great till now i think they tring to make us use 3g data so they make more money...
     
  16. wc3sam macrumors newbie

    Joined:
    May 25, 2009
    Location:
    baltimore
    #16
    IOS 5.1 WIFI problem fixed

    OK guys I have found a way to fix the problem on all IOS devices just go in to the wifi setting and click on the router name you use and turn the proxy to auto and problem fixed. Sam
     
  17. Kb1984 macrumors newbie

    Joined:
    Mar 15, 2012
    #17
    Negative that did not fix the problem.

    Also sign me up, once I updated to 5.1 my iPhone now no longer connects to my wi-fi. LAME!
     
  18. teodor macrumors newbie

    teodor

    Joined:
    Aug 19, 2010
    Location:
    Slovenia, Maribor
    #18
    Same here!

    I did fresh restore from iOS 5.0.1 to iOS 5.1 (iPhone 4). Set up as new device.

    It looks like the iOS cant remember the wifi network (more likely password).

    Some of my friends report the same. I think it's an iOS bug.

    I did some further research and try setting me router without password for the wifi network. And it's the same. After sleep it didn't connect.
     
  19. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #19
    This is what I've done to get it working again plus one more step - I go into my router settings and set the IP as static.
     
  20. teodor, Mar 24, 2012
    Last edited: Mar 24, 2012

    teodor macrumors newbie

    teodor

    Joined:
    Aug 19, 2010
    Location:
    Slovenia, Maribor
    #20
    This is wrong. Why would you need to change router setting because u updated the iOS.

    I've done some research again and found out, if u set on the iphone wifi setting for wifi network as static (ip,dns,mask,router..), it will connect immediately.

    Changing router setting it is just non-sense. Definitely is iOS problem or bug or something is wrong with it.

    Update #1 : Nop , this didn't work... sorry :(
     
  21. lamina macrumors 68000

    lamina

    Joined:
    Mar 9, 2006
    Location:
    From Canada, living in Seoul
    #21
    Whenever something weird like this happens, I do a DFU restore. Fixes it every time.

    That guide is old, but it still works the same way.
     
  22. teodor, Mar 24, 2012
    Last edited: Mar 26, 2012

    teodor macrumors newbie

    teodor

    Joined:
    Aug 19, 2010
    Location:
    Slovenia, Maribor
    #22
    @lamina

    Really ? Hmm i will try it later. I will be back with a report if it's working or not. Thanks for the tip for now.

    Update #1: DFU restore does not fix the problem. So this is no go.

    Update #2: I change the name of WIFI network and now it's working properly. But still it's weird, bug or something.
     
  23. mozbius macrumors newbie

    Joined:
    Oct 6, 2011
    #23
    I have a iPhone 4 iOS 5.11.
    I've noticed that , most likely since my upgrade from 4.21 to 5.11, I could only connect to my own wifi, secure wifi... but not on free/public/bars/shopping center wifi. The iPhone would try to connect. Get a dhcp IP then get disconnected when normally a safari web page should have shown up inviting me to login or press a button to access the public wifi.

    I have tried:
    * shutdowns of the iPhone
    * resets of networking settings
    * forgets of wifi connections
    * turning on/off wifi/Bluetooth/airplane mode
    * auto proxy
    * switch static ip
    * switch bootp
    * switch manual proxy
    * .....,

    Until I've noticed two options that don't show up when I connect to a secure/home/office network... :

    * Auto Join
    * Auto Login

    So I've set Auto Login to off and bam! What do you see! Full connection to that bar free/public wifi!!!!! I wanted to make sure that wasn't a fluke so I went to a drug store that offers free wifi for customers that are waiting for their prescriptions. This time I simply tried to connect as I would normally do. Again that didn't work. Connection would get established for like 40 seconds then IP and all network entries would disappear. So I did my newly found trick: set auto login to off .... BA-BAM!!!

    So before you go through the whole restore ordeal, gives this a try. :)
     
  24. akki macrumors newbie

    Joined:
    Oct 13, 2012
    #24
    hey guys, i have an iphone 4 running on ios 6 and it's wifi is not working(greyed out) but strangely wifi address is there in settings.guys tried everything but found no solution to it.
     
  25. GMAN5050 macrumors newbie

    Joined:
    Nov 5, 2012
    #25
    iphone 4 wifi connection problems

    This happened to me today. My phone would not find any wifi hotspots. I tried suggestion on this site and they did not work. What if finally did what a reset. By holding the Home Button and the Power Button together for a few seconds then it went into a reset mode. When restarted the wifi worked. I could see all wifi connections.
     

Share This Page