iPhone 4 using iPhone 3GS dock = No sound dock port?

Discussion in 'iPhone' started by QUiKSR20, Feb 6, 2011.

  1. QUiKSR20 macrumors member

    QUiKSR20

    Joined:
    Oct 12, 2008
    Location:
    Neptune, NJ
    #1
    If anyone could help me I would greatly appreciate it as I am having no luck.


    I have an iPhone 4 and an old 3GS dock which works fine with the phone.
    I can sync it to the computer with the dock charge it etc.

    So heres my issue :

    I recently got the Nissan OEM integration kit for my car and when I plug the cable into my iPhone 4 it works perfect!

    So I figured hmm if i can mount my dock in the car somewhere I can just dock it which would be easier than attaching a cable all the time.

    When I dock it all it will do is Charge. I get no audio, It seems its not transferring any audio over the dock port.

    Any help would be greatly appreciated.

    Thanks,
     
  2. LoganT, Feb 6, 2011
    Last edited: Feb 6, 2011

    LoganT macrumors 68020

    Joined:
    Jan 9, 2007
    #2
    Are you sure the iPhone 3GS dock works with your iPhone 4? Because mine doesn't fit at all. The only thing I can think of is that possible found a way to force the iPhone 4 into the 3GS dock and the 30 pin connector is connecting just enough to charge the iPhone but not have audio pumped out of it. I doubt that's possible though.
     
  3. QUiKSR20 thread starter macrumors member

    QUiKSR20

    Joined:
    Oct 12, 2008
    Location:
    Neptune, NJ
    #3
    Hey sorry forgot to include that I popped off the plastic top of the dock so you can just see the exposed circuit board. Nothing has been modified on the board but the plastic covering is removed so it fits 100%
     
  4. Airmark1 macrumors regular

    Joined:
    Jul 26, 2008
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    You are getting sound over the iPhone speaker right while not docked right? Sometimes it gets sticking in "headphone" mode.
     
  5. QUiKSR20 thread starter macrumors member

    QUiKSR20

    Joined:
    Oct 12, 2008
    Location:
    Neptune, NJ
    #5
    Yeah im not sure whats going on, I have rebooted the phone tried tons of diff ways. If I plug right into the dock wire from my OEM integration kit in my car it works. If I plug that wire into the dock and then place my phone on the dock I only get charging. No Audio.
     
  6. DoctorK4 macrumors regular

    Joined:
    Jan 31, 2011
    #6
    It's possible that the pins (in the 30-pin connector) that carry line out audio are not passed through the female 30-pin connector on the back of the dock. It wouldn't really need to pass the line out audio through that connection, since there's an 1/8" jack for line out.

    Just a thought...
     
  7. QUiKSR20 thread starter macrumors member

    QUiKSR20

    Joined:
    Oct 12, 2008
    Location:
    Neptune, NJ
    #7
    Your totally correct that's what I am thinking. Does anyone know of a dock that does? I'm hoping to get a dock, crack open the case and just mount the internals in my car so I can dock my phone and listen to pandora / ipod etc.
     

Share This Page