iPhone 4 video streaming stops loading after a few seconds

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dpchevy2000, Sep 24, 2010.

  1. dpchevy2000 macrumors newbie

    Joined:
    Sep 24, 2010
    #1
    I've literally been searching for days on this topic, but I've been unable to find anything that pertains to my circumstances.

    Any streaming video (whether it's within the YouTube app, YouTube mobile site, a different app, etc.) will start to play and get through about 8 seconds before freezing up due to a halted file load. If it's a short video where the amount of buffer can be seen on the progress bar, it will load part way and then stop completely. Once the video catches up with the buffer, the video obviously stops playing.

    It does this for 99% of streaming videos I try to watch, so at this point I've pretty much given up on being able to watch video on my iPhone. Videos I've actually saved on my phone via iTunes play without any issue, so it appears to be a streaming issue.

    My girlfriend has a 3gs and I have a 4g. Both are up to date running iOS 4.1. We're on the same WiFi network, 3 feet from each other, and while I am unable to watch a video she is able to watch the exact same video.

    Everything is up to date, not jailbroken, tried resetting to no avail. Any ideas other than trying to get a new phone from Apple?
     
  2. simewich macrumors newbie

    Joined:
    Aug 6, 2009
    #2
    I have the same situation but the time I'm into a video before it stops varies. I have an iPhone 4. And trying to skip a few seconds ahead doesn't work. It usually starts the video timer but no video or sound.
     
  3. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #3
    Same here. I can usually babysit the video to get it to play. I have to pause the video at the beginning then let it buffer to the point where I won't catch the end of the buffer while I'm watching. If I do catch up with the buffer it will stop buffering. I have done a complete clean install (for other reasons) and this still happens. I think it has to do with the iP4 dealing with HD content. VERY FRUSTRATING!
     
  4. Bandolier macrumors 6502a

    Joined:
    Aug 2, 2010
    #4
    Same issue with jailbroken iPhone 4. All streamed video will not load correctly. It will load, stop, I have to press Done to exit the video and try it again and pause and play the video by myself. It does not continue to buffer once it catches up to the buffered video. Not an issue with my Internet because non jailbroken iPhones sitting next to me will load the exact same video perfectly and I get consistent results.
     
  5. Al3x87 macrumors member

    Joined:
    Sep 13, 2010
    #5
    4.1 iOS it's not up to date. Upgrade it to 4.2, then we will talk.
     
  6. sanderlebau, Apr 20, 2011
    Last edited: Apr 20, 2011

    sanderlebau macrumors newbie

    Joined:
    Apr 20, 2011
    #6
    same problem on iOS 4.3.2

    I am running 4.3.2, which IS up to date, and I have that exact issue.
     
  7. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #7
    Use the mobile version of YouTube. Go to YouTube from Safari and use the Add To Homescreen feature to use it as your YouTube. It work MUCH better than the outdated version Apple is using in the current iOS. It has the ability to play a HQ or lores version. Also, what I do if I'm sent a link (as it will want to open in the iOS YouTube app) is to favorite it then go to the mobile version and play it there.
     
  8. dpchevy2000 thread starter macrumors newbie

    Joined:
    Sep 24, 2010
    #8
    Figured out this issue

    This thread is a little old and I'm now a Droid user but figured I'd update with the solution to my original issue, with the hopes that it could help someone else avoid a great deal of frustration.

    My video would NEVER stream on my iPhone, but I noticed it did the same on my AppleTV, rendering it pretty much useless. Long story short, the problem was that my Apple products didn't work with wireless-N. Every other computer, tablet, etc. in my house that streamed via WiFi did so without incident, but the Apple products never worked. I switched my wireless router to broadcast wireless-G and problem solved, everything works fine now. If you have this problem and you have a wireless-N router, change the mode to G. Seems counterproductive that Apple products don't work on the better wireless networks. Since this thread is over a year old, I would hope they fixed the issue by now.
     
  9. thefoolangel macrumors newbie

    Joined:
    Feb 21, 2008
    #9
    Thanks for that, very helpful!
    I too had trouble finding the answer to this annoying problem. Changing my BT HomeHub router to B/G only fixed it.

    Cheers
     

Share This Page