iPhone 4 - Want to buy but can I jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by muran, Aug 21, 2010.

  1. muran macrumors newbie

    Joined:
    Aug 21, 2010
    #1
    Simple, quick question ...

    If I buy an iPhone 4 tomorrow and find it has iOS 4.0.2 out of the box, am I right in thinking I have had it as far as jailbreaking is concerned - ie there is no way to restore to 4.0.1?

    As I understand things, after reading many posts I gather that I would have to wait until the iPhone dev team or jailbreakme have a release for the latest software version.

    Would appreciate confirmation as this will determine whether I buy the iPhone 4 or not.

    Thanks.
     
  2. ajax43 macrumors regular

    Joined:
    Jun 16, 2010
    Location:
    North America
  3. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #3
    Yep if it has 4.0.2 you're out of luck until 4.1 is released and a jailbreak is developed for it. It's your gamble
     
  4. muran thread starter macrumors newbie

    Joined:
    Aug 21, 2010
    #4
    Thanks guys, as I thought.

    I guess I either buy and hope it's 4.0.1 although I would assume Apple stores are stocked with 4.0.2 models now - or I buy anyway and use without jb until such time as jb is possible.

    Will the people in the know not bother with jailbreaking 4.0.2 then? If not, anyone care to have a stab in the dark (or an educated guess) as to when we might see 4.1 and a subsequent jb solution?
     
  5. muran thread starter macrumors newbie

    Joined:
    Aug 21, 2010
    #5
    Scratch that, this answers my question :)
     
  6. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #6
  7. thespazz macrumors 6502a

    Joined:
    Jul 5, 2007
    #7
    I don't know if this is serious or sarcastic, but why be a douche, dude?
     
  8. ajax43 macrumors regular

    Joined:
    Jun 16, 2010
    Location:
    North America
    #8
    You may get lucky on the firmware. I just bought my iphone 4 16 gb Thursday, and when I got home it still had the 4.0.1 firmware. so I jailbroke no problem with jailbreakme.com. Others on another forum I frequent here in Canada noted that they just picked up their new iphones and had the 4.0.2 firmware, so it's a crap shoot.
     
  9. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
    #9
    Be careful if you happen to have 4.0.1. If you install something that is not compatible/messes your phone up, you will have to restore to 4.0.2.
     
  10. gravytrain84 macrumors 6502a

    gravytrain84

    Joined:
    Jun 24, 2010
    Location:
    LA
    #10
    Labman =

    [​IMG]
     
  11. gravytrain84 macrumors 6502a

    gravytrain84

    Joined:
    Jun 24, 2010
    Location:
    LA
    #11
    I would have to realllly screw up my phone in order for me to restore at this point... I've d/l a few things that threw me into safe mode but I was always able to go into cydia, delete problem app, and move on.
     
  12. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #12
    What, thespazz is back?!
    And why all the hate for labman? hes just sick of new topics when people have not googled.
     
  13. SeanZy macrumors 6502a

    Joined:
    Dec 29, 2008
    #13
    You can always buy one from Apple, sell it on craigslist, and then buy a different one from craigslist haha
     
  14. thespazz macrumors 6502a

    Joined:
    Jul 5, 2007
    #14
    thespazz with two Zs, not one like TheSpaz.
     
  15. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #15
    Thank you Benji222 Exactly my point was simply the TS found his own answer something about 70% can't do. So muran if you want to turn me into a hatter that's ok. but considering that A you don't know me and be have no idea how many times the same things are asked over and over again. As you found most of stuff can be answered almost immediately though searching. Ok the jerk is done for now.
     
  16. Silenthillnight macrumors member

    Joined:
    Aug 12, 2009
    #16
    Did you know there's at least 20 different websites that demonstrate how to cook normal scrambled eggs? You should be glad he found the answer he was looking for. No reason to get Don Rickles on him :)
     
  17. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #17
    Ok my bad muran I'm a idiot I'm sorry . I have been properly put in my place and in check, I thank you all. :D
     
  18. SL4VE macrumors 6502

    Joined:
    Aug 19, 2010
    #18
    i bought an iPhone4 on last thursday on 4.0.1 hth
     
  19. brunetmj macrumors member

    Joined:
    Jul 9, 2010
    Location:
    Upstate, NY
    #19
    I hate to state the obvious but just check the phone before you buy it.
    Settings will tell you what you want to know
     
  20. duranross macrumors newbie

    Joined:
    Aug 23, 2010
    #20
    Just got an Iphone 4, came with 4.0!!!! Very odd, it is from Three (UK).

    I have tried to update to IPSW 4.0.1 but it tells me my iphone is not eligable, as in I beleive apple has stopped signing the 4.0.1 upgrade.

    I have tried to search but cannot find a way to upgrade.

    Would you recommend just upgrading to 4.0.2 then downgrading to 4.0.1 - would that work?

    Thanks!

    At the moment using JB 4.0 and the signal problem is terrible
     
  21. winterny macrumors 6502

    Joined:
    Jul 5, 2010
    #21
    4.0.1 changes the signal bars calculation and image, but didn't change anything in the radio firmware, so it will have no difference in actual coverage

    4.0.2 fixes the jailbreakme.com bug, but has no other improvements.

    If you upgrade from 4.0 to 4.0.2, you will not be able to downgrade.

    Leave it at 4.0 if you want to JB, and be very careful not to do something that will cause you to have to re-install, as you'll lose your jailbreak, since you don't have SHSH blobs saved.
     
  22. duranross macrumors newbie

    Joined:
    Aug 23, 2010
    #22
    GOTCHYA!!

    Thanks for clearing that up for me.

    I'll wait for 4.0.3 or whatever next has a JB thanks.
     

Share This Page