iPhone 4 wifi problems?

Discussion in 'iPhone' started by csmitty, Jun 30, 2010.

  1. csmitty macrumors regular

    Joined:
    Sep 15, 2007
    #1
    Mine is having problems pulling data over wifi at times. Like right now. I have a N and G network setup, the G was just for my iphone 3G and what the 4 is connect to. Most of the time it works fine. Now safari is saying it cannot open page server stopped responding. Any data apps won't connect either. However I'm posting this on the same network. Even switched to the G band to make sure.

    Sometimes it works fine. Others nothing will load. A reboot didn't help.

    anyone else having similar problems

    Edit: Ok so somehow the phone thought its IP address was in base 10. a lease renew set it back right to 192. Weird.
     
  2. myjay610 macrumors regular

    Joined:
    Jan 6, 2008
    #2
    I was having an issue where it would remain connected to the WAP but just stop routing data all together. I noticed it happened with my MBP too though...do any of your other WiFi devices have issues? I ended up changing WAPs and it has been working fine.
     
  3. csmitty thread starter macrumors regular

    Joined:
    Sep 15, 2007
    #3
    Nope, my MBP was connect to the same G network and was running just fine.

    Somehow the IP address got changed on the phone (I didn't do it) and the lease renew set it back straight. Will have to see if it happens again. Everything is running DHCP. Only one device, the iphone, on that network so shouldn't have been a IP addy conflict.
     
  4. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #4
    Havnt wifi problems here aswell. The connection stays on and displays full bars but it regulary drops off and only loads slowly, half pages when browsing.
     

Share This Page