iPhone 4 won't backup, please help!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nickel586, May 14, 2011.

  1. Nickel586 macrumors newbie

    Joined:
    May 14, 2011
    #1
    Hi,
    I am on a jailbroken iPhone 4 with iOS version 4.3.1 and on Windows with iTunes 10.2.2.14. Every time I plug my iPhone into the computer, it immediately begins to sync and never backs up. I did some searching online and was told to delete my previous back up (which was over a month old) and then try to re-sync, but still no back up. When I right click my device, there is no back up option. Am I missing something or has anyone run into this yet? Any help is appreciated as I'd like to go ahead and update, but now have no back up at all of any of my contacts, SMS, etc. Thanks in advance!
     
  2. Hodgo71 macrumors newbie

    Joined:
    May 28, 2011
    #2
    G-Day mate,

    I wish I could help you out. I have EXACTLY the same issue. I have been googling this problem for the past few days and the only thread/post I can find anywhere with this same issue is your post here...! But sadly there is no response or fix.
    My phone is also a iPhone 4, jailbroken on 4.3.3 and using a mac with iTunes 10.2.2.
    My phone has always backed up no worries at all, and as with you, I deleted the old back up and then went to re-sync/backup again but now it will only sync with no backup. The right click 'backup' option also as with you, no longer exists....
    Everywhere else on the web it says get the latest software for your phone/iTunes which I have; SO yeah I'm in the same boat mate. STUCK.
    I'll be very annoyed if my phone crashes now and I can't restore from a backup....

    Has anyone got any further suggestions on a possible solution/fix for this issue...??? Any help would be greatly appreciated.

    Cheers,
    Simon.
     
  3. Lyndo99 macrumors newbie

    Joined:
    Apr 20, 2011
    #3
    bump, i'm having the exact same issue with my iPhone 4 on 4.3.1, iTunes 10.4.0.80. Does anyone have any insight into why we are getting this problem?

    i do have the option to click backup when i right click on my iPhone unlike the OP, it will never successfully do it though. the error i get is:

    "iTunes could not backup the iphone "....." because the backup is corrupt or not compatible with the iphone" and then prompts me to delete the backup, which i have, but it didn't change anything.

    I am jailbroken using redsn0w
     
  4. Lyndo99 macrumors newbie

    Joined:
    Apr 20, 2011
    #4
    okay i got it fixed. The problem was that the permissions to some of the folders leading to the backup folder were set to "deny everyone" for some reason. the destination folder to the backups is: "C:\Documents and Settings\username\Application Data\Apple Computer\MobileSync" on my way there, both the documents and setting folder and application data folders were set to deny everyone.

    To change this all you do is right click->click properties->go to the security tab->click advanced->change permissions->click edit on the one that is denying access-> and then check full control. Problem solved!

    At the same time that i changed the permissions, I also changed the name of the old backup folder so that itunes would create a new one but i don't suspect that this is what fixed the problem.

    Hopeefully this will help someone else who has the problem in the future and/or helps the posters above me if they havent fixed it yet.
     

Share This Page