iPhone 4 won't boot, but can enter DFU

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dylansearle, Feb 20, 2013.

  1. dylansearle macrumors newbie

    Joined:
    Feb 20, 2013
    #1
    So my iphone randomly powered off, apple logo wont even come up. I can't seem to get it into recovery mode, but I can boot it into DFU mode (pc recognizes it as an iphone in recovery mode) itunes wont restore it (gives me errors after trying). I just want to get it running, I have no problem with jailbreaking it if thats my only option to get it running, I tried previously but don't seem to have much luck (I once got the recovery mode screen to pop-up on the iphone). I tried to jailbreak with redsn0w and it gets stuck at the uploading first stage screen. I got past that once, but then it gave me a missing keys.dll error. Is there anything I can do at all to get it working or is it just done?

    Any help would be awesome!
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  3. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #3
    It's given me the 1601 error as well as a 3164 and several others.
    I know the solution can sometimes be trying a different computer, but it gives me the same error when trying my laptop. Both are running win7.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    What version of iOS are you trying to restore to?
     
  5. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #5
    I believe its currently on 6.0, it downloaded the 6.01 sofware update via itunes when I tried to restore (I believe that's the newest one) and tried to update and restore. So i'm not sure if it actually updated. If not then it's on 6.0 and thats what I was trying to restore to via jailbreak. If itunes did update it to 6.01 but couldnt restore would that be why a jailbreak couldnt work as I was using a 6.0 ipsw?
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    Apple isn't signing iOS 6.0.X anymore. Restore it to iOS 6.1.2.
     
  7. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #7
    So download a 6.1.2 ipsw, enter DFU mode, open itunes, shift+click restore and select the 6.1.2?
     
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    Enter plain DFU mode and just click Restore. Nothing else.
     
  9. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #9
    That doesn't work, thats what gives me the errors.
     
  10. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #10
    Check your hosts file for any references to apple.com and remove them. Use a search engine to find out how to locate and edit the hosts file for your system.
     
  11. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #11
    I'll try again when I get home and update afterwards.

    ----------

    I've already checked the host file in windows/system32/drivers/etc, but there is no mention of apple in there.
     
  12. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
  13. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #13
    You're getting that error because you're trying to restore to a firmware other than 6.1.2 or your hosts file isn't correct. Verify your hosts file, restart your machine, and make sure iTunes is restoring iOS 6.1.2.
     
  14. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #14
    If I just click restore shouldnt it automatically restore to 6.1.2? And my hosts file is default. No mention of apple or anything in it.
     
  15. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #15
    I tried again to no avail. iTunes still gives me error 1601 when I try and do a regular restore. I actually got redsn0w to complete and say it was done yet nothing pops up on the screen.
     
  16. DerekRod macrumors 6502a

    DerekRod

    Joined:
    Jan 18, 2012
    Location:
    NY
    #16
    You're using redsn0w?Just use itunes and if you have tinyumbrella make sure TSS server isn't running that could also be it
     
  17. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #17
    I also tried using itunes, gives me error 1601. And I don't have tinyumbrella, what do you mean?
     
  18. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #18
    I put it into pwned DFU mode using sn0wbreeze then did a regular update with itunes and the apple logo came on and said it was restoring but after about 10 min it gave me an error and quit. I believe it was (-1) and I retried and the recovery screen showed up and after trying to restore again it gave me error 1611.
     
  19. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013
  20. Ryan Burgess macrumors 6502

    Joined:
    Jan 26, 2013
    #20
    Put the iPhone in recovery mode, (google how if you dont know) then try restoring again through iTunes. Worked every time for me! :D
     
  21. dylansearle thread starter macrumors newbie

    Joined:
    Feb 20, 2013

Share This Page