iPhone 4 won't charge/turn on anymore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by yungplayz, Jun 8, 2013.

  1. yungplayz, Jun 8, 2013
    Last edited: Jun 8, 2013

    yungplayz macrumors newbie

    Joined:
    Jun 8, 2013
    #1
    General description of issue:
    iPhone 4 used to function normally, but after a couple weeks lying around won't charge anymore, neither will it turn on (shows insufficient charge animation even if connected to AC).

    Details:
    Around half a year ago I purchased an AT&T iPhone 4 32 GB for myself, factory unlocked it and started using it right away. April, 3rd was my brother's birthday and I decided to present him this iPhone, so I replaced front panel and middle frame with brand new items, gave him the iPhone and it was still functioning. But I was in a big hurry, so I forgot to put anti-dust mesh and bottom screws on their places before handing an iPhone in to him.
    The following paragraph may or may not concern the topic, so I'm mentioning it just for the case:
    My brother went to Kazakhstan for a couple weeks to shoot a movie and in Kazakhstan this iPhone wouldn't work with Kazakhstan local carriers' SIMs, while his old iPhone 3Gs worked just fine. (Both the iPhones worked with Ukrainian carriers' SIMs like they should).
    Once back home (Ukraine) in mid May, he gave me the iPhone so I could install the missing mesh and screws, but I have lost the original mesh by then and due to exams in my University had no time to go to radio market and for a new one. So for a couple weeks his iPhone just lied on my bedside and ABSOLUTELY NOTHING was happening to it, it wasn't even touched a single time. Once I finally purchased a new mesh on market, I first tried to turn the iPhone on to check if everything else is working properly and found out it won't boot or charge anymore. It just shows the animation with red battery, AC adapter and drizzle.

    My conditions:
    I got several iPhones 4 so I can replace any detail needed if that doesn't require soldering, because my soldering skills are too low to solder something as small as cellphone's motherboard's details.
    Also, bringing the iPhone to Apple Store to try solving the issue with their help somehow is not an option, due to nearest Apple Store being located a couple thousand miles away.

    What would you suggest? :confused:
    Thanks in advance! :)
     
  2. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
    #2
    Try a different USB cord and connect it to a computer. Check to see if the device manager recognizes it. If you already plugged into a computer, try different USB ports or a different computer all together. If possible, use a different cable and wall adaptor and plug into ac outlet and post back.
     
  3. yungplayz, Jun 12, 2013
    Last edited: Sep 30, 2013

    yungplayz thread starter macrumors newbie

    Joined:
    Jun 8, 2013
    #3
    I now have to grant myself the dumbest person alive reward. Turned on with a different battery. Nothing else was replaced, only the battery itself. Thread not closed due to my hope that somebody knows and will explain me, what could have theoretically killed the old battery whilst absolutely nothing was happening to the phone.
     

Share This Page