iPhone 4 won't update apps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by markcamilleri10, Sep 1, 2011.

  1. markcamilleri10 macrumors newbie

    Sep 1, 2011
    Whenever I try and update an app on my iPhone 4 I get the message 'Cannot Connect to iTunes Store'. But, if I try to download a new app it works fine. Do you guys have any ideas for something I can do to fix this?

  2. testcard macrumors 68040


    Apr 13, 2009
    Northumbria, UK
    Have you tried signing out of your iTunes account and then signing back in again? Can you update apps on your Mac/PC?
  3. adularia macrumors newbie

    Oct 20, 2011

    i'm having the same problem...did you ever figure out how to fix it? i tried a restore and it didn't work.
  4. shadedred macrumors member

    Feb 5, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Same problem here. Looks to be widespread. I have apps that aren't updating, apps that are updated but still show as needing to be. Also if you try a search on the app store from your phone, nothing will appear.
  5. hugodrax79 macrumors newbie

    Oct 19, 2011
    Derby, UK
    Hi guys, i've got the same problem. This has occurred since I updated to iOS5. Has anybody found a solution to it?
    I took my iphone4 into a store and saw a genius and after playing around with my phone for a bit all they did was delete the apps that were there to update and downloaded them again as new. Which was fine for the free apps but for the apps that I paid for its telling me I need to purchase it again. :mad:

Share This Page