iPhone 4 Youtube not working over WiFi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by drahcirnaw, Jul 26, 2010.

  1. drahcirnaw macrumors newbie

    Joined:
    Jul 12, 2010
    #1
    I just got my iPhone 4 today and I was trying to play a YouTube video over my WiFi network. However, when it is supposed to start playing, it says it cannot be played. I've tried it over two WiFi networks in my house and it's not working. It is working over 3G though. Anyone know what the problem is? Thanks.
     
  2. culturekiller macrumors newbie

    Joined:
    Oct 11, 2009
    #2
    same here. just got mine at 2pm west coast time today. this is annoying me.

    also, working over 3g, but not wifi.

    and my wifi doesnt even have a password thing.
     
  3. drahcirnaw thread starter macrumors newbie

    Joined:
    Jul 12, 2010
    #3
    Yeah, I called Apple support and the lady said it's normal? She said that YouTube works when it wants to even on her iPhone so I have no idea what's going on here...
     
  4. bluer101 macrumors regular

    Joined:
    Jun 22, 2010
    #4
    Don't use the app, use safari and go to m.youtube.com. See if that helps.
     
  5. iphones4evry1 macrumors 65816

    iphones4evry1

    Joined:
    Nov 26, 2008
    Location:
    California, USA
    #5
    Do you have an iPhone 3G sitting next to the iPhone 4 so that you can compare then side-by-side? The old iPhone still works on WiFi. I have not noticed a difference with the iPhone 4. My iPhone 3G loaded Youtube vids quickly sometimes and like a snail at other times. Same with the iPhone 4. With all smartphones, there are some Youtube videos that say "cannot be played on mobile," and there are other videos that can be played on mobile. Be sure it's the phone and not the video.
     

Share This Page