iPhone iPhone 4S 5.0.1 jb won't connect to PC

Discussion in 'Jailbreaks and iOS Hacks' started by colonelcavecat, Nov 7, 2012.

  1. colonelcavecat macrumors newbie

    Joined:
    Nov 7, 2012
    #1
    Hi there,

    Recently my phone got knocked into some water. After giving it the rice bath treatment for a few hours it seemed to have recovered just fine, however now my phone will not connect to PCs.

    I have tried it on various PCs (all running windows 7) with various USB cables, and in each case there is no response from the PC or from the iPhone. This includes no charging icon, no recognition from iTunes, and the PC does not come up to say the USB device is not recognised. It will still charge from a powerpoint.

    As it is jailbroken I want to restore it before I get it looked at, however as the problem is it won't connect to the PC I'm not able to restore it. Good old catch 22 going on.

    I have tried putting it into DFU mode, however there is still no response. Interestingly enough, when I turn the phone off while it is plugged in to the PC, the system sounds for a new device are played.

    The only thing I can think of trying is updating to 6.0.1, however I am concerned this will then brick the phone. My phone is insured, I am considering reporting it lost or stolen to replace it if I can't get it up and running again.

    If anyone has any ideas as to how I can fix this it would be greatly appreciated.
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    did you try TunyUmbrella and see if it recognizes the phone?
     
  3. colonelcavecat thread starter macrumors newbie

    Joined:
    Nov 7, 2012

Share This Page