iPhone 4S and internet connection via hotswap USB cable not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by zillah, Nov 14, 2012.

  1. zillah macrumors newbie

    Joined:
    May 29, 2008
    #1
    Dear Experts

    I have got iphone 4S I used to enable the Personal Hotswap and connect my laptop via USB cable to connect to the internet,,,,,,everything was working fine for a while.


    Now I am not able to access the internet via USB cable any more although I tried different USB ports on my laptop ASUS U31S windows 7 ultimate.


    http://i46.tinypic.com/2iiv2n9.png


    Though still I can access the internet via Wi-Fi iphone Hotswap.


    Could you please advise what troubleshooting should I consider to rectify this issue ?


    Regards
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Have you tried restarting your phone?
     
  3. zillah thread starter macrumors newbie

    Joined:
    May 29, 2008
    #3
    Yes I did restart the phone couple of time without any joy

    Thanks
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Ok ctrl+alt+delete and close all apple services in the processes tab including iTunes.

    Then plug your phone in with hotspot on but wifi on your laptop set to off!!

    You should see a pop up in the bottom right saying installing device driver after which it should work.

    Remember wifi supersedes a wired connection when tethering as it thinks the cables there for power.
     
  5. zillah thread starter macrumors newbie

    Joined:
    May 29, 2008
    #5
    Hi Gav2K

    Good point I wasn't aware of it.

    I tried that and it didn't fix the problem but the tip gave me an idea to uninstall all iphone software and drivers and iTune from the computer then fresh installation and now the internet via USB cable is working

    Regards
     

Share This Page