iPhone 4s camera fault?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Xorro, Jul 31, 2012.

  1. Xorro macrumors regular

    Xorro

    Joined:
    Dec 19, 2008
    Location:
    UK
    #1
    Hi,

    when using my iPhone4s to take stills or movies I occasionally get pink and green striping across the image. With the attached movie there were also solid blocks of pink obscuring the image.

    Has anyone else experienced this, or know how to sort it out? I've had the phone since release and it started doing this about 2 months ago.

    http://www.xorro.co.uk/temp/IMG_0350.JPG
    http://www.xorro.co.uk/temp/IMG_0342.MOV

    Many thanks

    P.S. Yes, I know they are upside-down!
     
  2. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #2
    Most likely hardware failure, especially if it's been going on for a couple of months. Take it, and your camera roll (evidence) to the Apple store. Should be under warranty still.
     
  3. Xorro thread starter macrumors regular

    Xorro

    Joined:
    Dec 19, 2008
    Location:
    UK
    #3
    Made it to my nearest Apple store last night, they said they'd never seen this fault before.

    The chap tried replacing the camera module, after which the camera app wouldn't open.

    So now I have a new iPhone :)
     
  4. aircanman macrumors 6502

    Joined:
    Feb 2, 2011
    Location:
    UK
    #4
    I never knew they went inside the iPhones in the stores, it used to be a swap out, nice that you have a new iPhone though!!
     

Share This Page