iPhone 4s can't connect to iTunes on Mountain lion

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Gabri, Jul 30, 2012.

  1. Gabri macrumors member

    Joined:
    Aug 21, 2011
    #1
    This is a new MBP & this is the first time to connect my iPhone to it after transferring my library from my PC to the Mac through home sharing.

    When I connect it I get this error from iTunes http://cl.ly/image/1G1Z3V1P0Y1I while iPhoto can detect it normally & actually import all the photos from it without a problem.

    I restarted both devices but the problem still exists. The Cable is good cause I tried it on the PC it's working. So I don't know how can I fix this?
     
  2. iNiqoro macrumors newbie

    iNiqoro

    Joined:
    Nov 12, 2011
    Location:
    Aberdeen, United Kingdom
    #2
    Restore is probably the only way

    :apple:

    Hey,
    I have a similar problem with my iPhone 4s that was firstly synchronized with my Lion but now I went back to Snow Leopard (don't ask why :)). So, now running iOS 5.1.1 I cannot sync with my iTunes although iPhoto works fine.

    I have tried everything:
    Restart iPhone and Mac
    Reinstalled iTunes version from my Time Machine (some say the old library might work if copied over)
    Reset SMC controller
    Reset settings on iPhone

    So I guess the only thing that works is a restore of your iPhone.

    I haven't done it yet, because I am still trying to make a backup on iCloud.

    Good Luck, ​
     

Share This Page