iPhone 4S Crashing,

Discussion in 'iPhone Tips, Help and Troubleshooting' started by soccers56, Nov 8, 2011.

  1. soccers56 macrumors newbie

    Joined:
    Nov 8, 2011
    #1
    So I have an iPhone 4S from Verizon, which worked fine for the first few weeks. Last week it began to act up: first, it would shut off while just being in my pocket, which would happen usually 2-3 times within half an hour and then work fine for several hours/days. It continued like this many times, each time accompanied by a log in the diagnostics called panic.plist (see below). I'm not sure if this is related, but at around the same time, many of my recent calls and sms messages would only have the phone number displayed, even though I did still have the contacts saved in my Contacts (so the name should have replaced the phone number). Also, when I continued sms conversations, often the iPhone would often start a new conversation instead of linking them all together.

    Here's what I've done so far. First, I did a hard reset several times, with no effect. I tried to restore all settings, and again the phone would crash/restart on its own. On the bright side, this fixed the phone/messaging contact problem. I then restored the phone as a new phone, then restored from a previous backup. Still nothing. The most recent thing I did, after a visit to the apple store, was to restore the phone as a new phone and set up everything fresh. Since restoring this time, I have only set up my email and contacts (I have two email accounts, a MS Exchange and my Gmail account. I have contacts set up with google and with iCloud). I haven't even installed any additional apps yet. However, the phone still crashed three times last night, and now I don't know what to do. It hasn't yet restarted today, but I wouldn't be surprised it if lasts for a few more hours before it crashes again. What should I do? Any ideas on what's causing this problem? Hardware issue that needs replacement? I'm getting tired of setting up all my settings multiple times.


    Here's the diagnostics log from the most recent time that my iPhone crashed, named panic.plist:

    Incident Identifier: 792C37E3-8CB0-4F32-8602-028141C20267
    CrashReporter Key: 427a7d174fd1a6eae902328052c76168c473379a
    Hardware Model: iPhone4,1
    Date/Time: 2011-11-07 19:35:05.222 -0500
    OS Version: iPhone OS 5.0 (9A334)

    panic(cpu 1 caller 0x808446df): "i2c1::executeIICCommand XIP is still set; last write status 10010100 xfer 00000000 fifo 00000000\n"@/SourceCache/AppleS5L8940X/AppleS5L8940X-105.6/AppleS5L8940XI2C.cpp:273
    Debugger message: panic
    OS version: 9A334
    Kernel version: Darwin Kernel Version 11.0.0: Thu Sep 15 23:34:43 PDT 2011; root:xnu-1878.4.43~2/RELEASE_ARM_S5L8940X
    iBoot version: iBoot-1219.43.32
    secure boot?: YES
    Paniclog version: 1
    Epoch Time: sec usec
    Boot : 0x4eb856f7 0x00000000
    Sleep : 0x4eb8779c 0x000c504c
    Wake : 0x4eb8791e 0x00000009
    Calendar: 0x4eb8791e 0x0000382e

    Task 0xc085ed20: 8421 pages, 114 threads: pid 0: kernel_task
    Task 0xc085eac0: 218 pages, 3 threads: pid 1: launchd
    Task 0xc085e600: 1021 pages, 7 threads: pid 12: UserEventAgent
    Task 0xc085e140: 251 pages, 3 threads: pid 13: notifyd
    Task 0xc085e3a0: 546 pages, 11 threads: pid 14: configd
    Task 0xc085dee0: 13215 pages, 19 threads: pid 15: SpringBoard
    thread 0xc0ce28c0
    kernel backtrace: cfd73994
    lr: 0x8007bccb fp: 0xcfd739c0
    lr: 0x8007c2cf fp: 0xcfd739f0
    lr: 0x80016391 fp: 0xcfd73a08
    lr: 0x808446df fp: 0xcfd73a48
    lr: 0x808449b9 fp: 0xcfd73a70
    lr: 0x80374155 fp: 0xcfd73a80
    lr: 0x80373575 fp: 0xcfd73a94
    lr: 0x8021cf99 fp: 0xcfd73ac0
    lr: 0x803737fd fp: 0xcfd73afc
    lr: 0x8084e1fd fp: 0xcfd73b24
    lr: 0x8084ac05 fp: 0xcfd73b30
    lr: 0x8084aebf fp: 0xcfd73b44
    lr: 0x8084a9ad fp: 0xcfd73b60
    lr: 0x8084ad4d fp: 0xcfd73b74
    lr: 0x8021cf99 fp: 0xcfd73ba0
    lr: 0x8084acd7 fp: 0xcfd73bc8
    lr: 0x809e8c91 fp: 0xcfd73bf4
    lr: 0x8021c1fd fp: 0xcfd73c10
    lr: 0x809e8061 fp: 0xcfd73c28
    lr: 0x809e92c3 fp: 0xcfd73c70
    lr: 0x8021c1fd fp: 0xcfd73c8c
    lr: 0x809e7e85 fp: 0xcfd73cac
    lr: 0x809eb7e1 fp: 0xcfd73cec
    lr: 0x80232dfd fp: 0xcfd73d0c
    lr: 0x80233675 fp: 0xcfd73d40
    lr: 0x80231d35 fp: 0xcfd73e30
    lr: 0x8006bbad fp: 0xcfd73f18
    lr: 0x8001846f fp: 0xcfd73f3c
    lr: 0x8000d57b fp: 0xcfd73f6c
    lr: 0x80013b57 fp: 0xcfd73fa8
    lr: 0x800791e8 fp: 0x2fe1d9d0
    user state:
    r0: 0x2fe1d9e8 r1: 0x00000003 r2: 0x00000258 r3: 0x000010bc
    r4: 0x00000107 r5: 0x00000000 r6: 0x00000000 r7: 0x2fe1d9d0
    r8: 0x00000000 r9: 0x04d78029 r10: 0x00000003 r11: 0x00000000
    r12: 0xffffffe1 sp: 0x2fe1d
     
  2. TUD macrumors regular

    Joined:
    Feb 11, 2008
    #2
    My 4S has the same issue. :mad: It is a hardware issue and the phone will have to be swapped out (new phone will be a refurb). You can either visit the Genius Bar or call Apple Care.
     
  3. rov4416444 macrumors newbie

    Joined:
    Nov 20, 2011
    #3
    Agreed, this is a hardware issue. The i2c1 you see in the first part of the panic message suggests this is a peripheral problem. You can read about I2C here. If you scroll to the "Applications" section, you'll see the type of peripherals that commonly use the i2c bus. It could be one of the volume controls, but this is really a guess. Your best bet is to have Apple swap it for one that isn't broken. If you've only had it a short time and didn't get it wet or drop it, I'm sure a trip to the Apple store will get it sorted out..
     

Share This Page