iphone 4s error 29 cant restore tried everything

Discussion in 'iPhone Tips, Help and Troubleshooting' started by trn600, Mar 21, 2014.

  1. trn600 macrumors newbie

    Joined:
    Mar 21, 2014
    #1
    So last Saturday I attempted to install the newest update on my iPhone 4s, and in the process it bricked. I cannot get it to recover/restore (forget which term is which) but I have tried doing it in recovery mode, and dfu mode with no success. I keep getting error 29 when it is verifying user data.

    Background: the day before the phone would be charging, but only if reset would it update the battery percentage. Additionally, the phone has water damage from over 8 months ago. I had the screen replaced in December. The geniuses offered little help and only did what I did before concluding it was a combo software/hardware error, what it was or how they came to that conclusion was not said to me.

    I really cannot afford a new phone, does anyone have suggestions/ past experience with this issue? I heard that replacing the battery may work.

    Thoughts?
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    At this point, I suspect the water damage may have caused enough corrosion to finally kill your phone.
     

Share This Page