iPhone 4S IOS 5.1.1 No Sim Card Installed/ICCID Unknown

Discussion in 'iPhone Tips, Help and Troubleshooting' started by A01, May 29, 2012.

  1. A01 macrumors newbie

    Joined:
    Feb 26, 2011
    #1
    Hey,

    So my 4S is a little bit dead. By which I mean, very dead.

    Upon updating to IOS 5.1.1 it decided that it didn't like my SIM card anymore. It wont read it at all. The phone just says there is no SIM card installed.

    Its current state is at the beginning of a new phone setup process. But it wont activate without a valid SIM obviously. If I click on the info thing on the first screen, it shows the IMEI - thats definitely there. But it says the ICCID is unknown.

    From what I've gathered from my googling so far, it appears to be a hardware failure.

    Is that definitely the case? Is there anything else I can try to do to get it working? (I've restored several times already and tried 2 SIM cards).

    Any help is really appreciated. Thank you! <3
     
  2. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #2
    Call the SIM and check for dirty contacts? Otherwise I think you're going to be seeking an Apple Store soon.
     
  3. A01 thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #3
    The SIM card appears to be fine. And I tried a brand new SIM too, just arrived yesterday and that doesn't work either.

    So I guess I'm off to the Apple store then. Which is a pain because it's ridiculously far away and will cost a small fortune to get there.

    The phone is under warranty but I don't have AppleCare for it. What are my chances of getting it replaced when I go to the store? I've never had to get anything repaired or replaced there before.
     

Share This Page