iPhone iPhone 4s keeps booting in safe mode after resetting settings

Discussion in 'Jailbreaks and iOS Hacks' started by Iphone4smaster, Apr 3, 2012.

  1. Iphone4smaster macrumors newbie

    Joined:
    Apr 3, 2012
    #1
    Wirelessly posted

    Hello, I reset my settings to factory settings(just settings) and now whenever I boot it it is always in safe mode. Also the cydia apps do not appear in settings. Do you know how to make it do it boots up regularly?

    I also tried uninstalling winter board with no avail, also sb settings
     
  2. HickDead macrumors 6502a

    HickDead

    Joined:
    Dec 2, 2011
    #2
    Most likely related to an incompatible app/tweak you installed.

    Solution: un-install the most recent app(s) one by one through Cydia > Manage > Packages...Remove (followed by a respring after EACH uninstall) to find the culprit.

    In most cases this resolves this type of issue. Good luck
     
  3. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #3
    Im not sure what you mean by reset your setting tomfactory settings. Did you go to the setting the use the erase all settings function?
     
  4. Farjad Uddin Ba macrumors newbie

    Joined:
    Apr 16, 2012
    #4
    Same problem with me. Happened on April 16 when I reset only the settings on my iPhone 4S. NEED HELP. ASAP.
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    if it is in safe mode install SBSettings again, that is never causing any problems and will allow you to go into safe mode from normal mode, is essential IMO.

    What you can do in SBsettings is go to more/Mobilesubstrate add ons.

    Disable your last installed tweak, or all of them and respirng with sbsettings.

    Now 1by1 enable the addons in SBSettings until you find the faulty 1.

    If you do so, go into safe mode, sbsettings again, and remove the tweak. Make sure that you enable tweaks in sbsettings before removing in cydia.

    good luck
     
  6. Farjad Uddin Ba, Apr 17, 2012
    Last edited: Apr 17, 2012

    Farjad Uddin Ba macrumors newbie

    Joined:
    Apr 16, 2012
    #6
    Thanks for the quick reply. I will try your method next time as for now the problem has been solved. I figured intelliscreenx was the culprit.
    Anyways thanks for your post.
    And your solution could not be used in my case as sbsettings was not even accessible in safe mode, and even in normal mode until intelliscreenx was removed.
     
  7. Sagarjain786 macrumors newbie

    Joined:
    Oct 13, 2012
    #7
    I was facing the same problem, then I uninstall mobile substraite this will also delet all cydia tweaks from setting but after respring board I am automatically exit from safe mode. Try it.....
     
  8. RoStep, Apr 22, 2014
    Last edited: Apr 24, 2014

    RoStep macrumors newbie

    Joined:
    Apr 22, 2014
    #8
    I was having problems with my camera leaving the app or never opening, so I reset all settings. Once it loaded, some of the tweaks that didn't work before started working (Bootlogos and more) but after it loaded it went to SAFEMODE. I keep respringing with no avail and this never happened before so it's not a tweak. No tweaks show up in the settings app. Please help me fix it. iPhone 4S iOS 7.0.4 [FIX: UNINSTALL CYDIA SUBSTRATE THEN REINSTALL IT. (Note: UNINSTALLING CYDIA SUBTRATE WILL AUTOMATICALLY REMOVE AL TWEAKS)]
     
  9. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #9
    Some tweaks don't show up in settings. Go into cydia and uninstall cydiasubstrate. You may need to change your view settings in order to see that package
     
  10. RoStep macrumors newbie

    Joined:
    Apr 22, 2014
    #10
    Yeah, I'm not uninstalling CydiaSubstrate. It will automatically remove every tweak I have already downloaded which is almost as good as restoring. I don't feel like writing down a list of tweaks and themes and such to download back and make my phone mine again. If you find something helpful, let me know.
     
  11. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #11
    Yes, that is the point. You said it's not a tweak related problem because you've removed all tweaks which implied you uninstalled all mobilesubstrate tweaks

    And in this post, you are contradicting that statement by saying you do have tweaks and don't want to uninstall them

    Aren't you saying you're constantly stuck in safe mode though? If that's the case, none of your tweaks that rely on cydiasubstrate are working
     
  12. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #12
    You are not supposed to reset all settings if jb. It will make a mess.
     
  13. RoStep macrumors newbie

    Joined:
    Apr 22, 2014
    #13
    My camera app wasn't working on my phone. But I just dealt with removing and reinstalling Cydia Substrate and losing all my tweaks. It fixed the problem and I'm okay now.

    ----------

    No. I said it's not a tweak related problem because I hadn't installed any tweaks before or after resetting all the settings. I uninstalled Cydia Substrate and downloaded it back and now it's fine... I just have to download all my tweaks again.
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    That just shows you it was in fact tweak related, or cydiasubstrate related

    Maybe you recently updated a tweak
     
  15. RoStep macrumors newbie

    Joined:
    Apr 22, 2014
    #15
    Actually, no. I hadn't had the problem until I reset all settings.
     

Share This Page