iPhone 4S, new update and Microcell

Discussion in 'iPhone' started by whitedragon7721, May 17, 2012.

  1. whitedragon7721 macrumors newbie

    May 17, 2012

    I've been having problem recently (within the last month) with my iPhone 4S and microcell from AT&T and it seems to have gotten a lot worse since I installed the new update a couple of days ago.

    The problem is that it will connect to the Microcell, I'll have 5 bars, it will say M-Cell but it won't connect to the cell service...meaning there will be no little 4G symbol next to the M-cell. Wireless works fine, etc. It used to be that everything would connect no problem upon returning home (where we have NO cell service) but now I have to turn off my phone and turn it back on to get cell service and sometimes that doesn't even work. Any ideas?
  2. xnickitynickx macrumors regular


    Mar 13, 2012
    Orlando, FL
    I'm not too familiar with it, but I don't believe it will say 4G next to it. I think it would just say M-Cell. But I may be wrong.
    As for not connecting, I'm a little lost. I think a call to AT&T might be in order :confused:
  3. dontwalkhand macrumors 601


    Jul 5, 2007
    Phoenix, AZ
    If you're at home, why not let the M-Cell handle calls, and use Wi-Fi for Internet? Unless the M-Cell isn't even working with voice.
  4. SAMtheGAM macrumors regular


    Mar 18, 2011
    Make sure Cellular Data is turned on. I get the 4G icon when I am connected to my microcell. Go to SETTINGS -> GENERAL -> NETWORK -> CELLULAR DATA

    The other thing I recommend doing is unplug the power to microcell for about 5 minutes and plug it back in. This will ensure your microcell will look for new software and update if necessary.

    My 4S automatically joins my microcell when I return home and my iPhone has the 5.1.1 update.
  5. whitedragon7721 thread starter macrumors newbie

    May 17, 2012
    It's iffy, I can send texts but not call out or receive calls and I can't listen to voicemail.


    Yeah cellular data is turned on. Mine used to work as well as yours does, lol. I tried resetting the M-cell but I'll try it again your way. It connects to the m-cell when I get home just not the cellular network. It's weird.

Share This Page