iPhone 4S "No modem firmware"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Madrassmus, Jan 24, 2012.

  1. Madrassmus macrumors newbie

    Joined:
    Jan 24, 2012
    #1
    Hi,


    I recently jailbroke my 4S and everything went just fine so I doubt this has anything to do with the jailbreak.

    However, I played around in the menu on my iPhone and accidentally (don't ask me how) clicked the delete and restore button. When I realized my mistake I quickly shut the phone off and I think I stopped it from restoring. But when I started my phone back up again, it said "Searching..." in the top left corner and in my settings "modem firmware" was completely empty. I have no idea what to do now. This is what I've tried so far:

    - Restore in iTunes (tried it in recovery mode, DFU) but I keep getting error messages saying I can't restore. Re-installed iTunes, changed hosts, tried several different ipsw files etc but it still won't work.

    - Delete and restore again on my phone but the phone just goes black and the spinning circle appears. I left it on at night and it just stayed in the same position throughout the whole time.

    I don't know what to do anymore. I didn't save any blobs unfortunately before the jailbreak so I can't load that.

    I've read about this problem for hours and hours and all I can find is people having the modem firmware blank along with bluetooth and wifi. But in my case it's only the modem firmware that's blank.

    Any suggestions? I'm going absolutely crazy here. :(



    -
     
  2. enoC macrumors 6502

    enoC

    Joined:
    Jul 2, 2009
    Location:
    Denmark
    #2
    As far as I know, you have have to click yes twice when deleting directly on the iPhone. So I doubt it was an accident....

    Anyway, have you tried another computer? Make sure you are in DFU-Mode. So the screen remains black right untill the actual restoring begins.
     
  3. Madrassmus thread starter macrumors newbie

    Joined:
    Jan 24, 2012
    #3
    I've made sure I'm in DFU-mode and everything. Anyone have any idea what to do?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    If a dfu restore doesn't help bring it to Apple.
     

Share This Page