iPhone 4s photo/camera problems - hangs on "Saving Photo"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by gunksny, Oct 24, 2011.

  1. gunksny, Oct 24, 2011
    Last edited: Oct 25, 2011

    gunksny macrumors newbie

    Joined:
    Jun 9, 2010
    #1
    Just got a new iPhone 4s and am having issues with the camera/photos.

    Everything worked fine initially (restored from a iPhone 4 backup) but I quickly lost the ability to send photos via email or mms - the camera app was hanging on "SAVING PHOTO", then the photo would appear in the camera roll as a black box, but the last photo could be seen in the little preview window on the left side of the camera app control bar.

    When scrolling through photos in the roll, some older photos look half blurry as if partially rendered. iPhoto will not recognize any of these photos. I am backing up contacts to iCloud but do NOT have Photo Stream enabled. I've tried disabling iCloud completely but it has no effect.

    After a restore to factory settings, I can take and send pics fine, but then when I restore from my backup, problems come back which leads me to believe its a configuration issue maybe due to permissioning.

    Finally, I did a restore and reconfigured all the other settings/apps from scratch. The phone now takes photos and I can send them, but iPhoto still won't recognize them. Additionally, if I take a photo then delete it, it will still show in the preview window on the control bar of the camera, but its not in the camera roll and I still get some half rendered images. Oddly, this only seems to occur when I'm attached to WIFI - as if its trying to sync with iCloud or iTunes, but I have that disabled.

    Anyone run into these issues and hopefully have a resolution?

    Thanks
     
  2. nperner macrumors newbie

    Joined:
    Oct 25, 2011
    #2
    I'm having the same problem on both WiFi and 3g. Everything worked just fine for the first week or so, but the last few days the camera gets stuck saving images. I've since disabled iCloud and tried everything noted above, but to no help.
     
  3. gunksny thread starter macrumors newbie

    Joined:
    Jun 9, 2010
    #3
    Did you do a restore to factory settings vis itunes and set up as a new phone? (ie. not a restore from a previous backup?) It should work at that pt. Then you just need to add and organize all your apps again and configure mail and settings. Painful.
     
  4. adi.utham macrumors newbie

    Joined:
    Oct 27, 2011
    #4
    I'm experiencing the exact same problem on iPhone 4 running iOS 5. Anybody pls help...!!!!!!!!!!!!!!!!!!!!
     
  5. Lukas77 macrumors newbie

    Joined:
    Oct 28, 2011
    #5
    I'm also having the exact same problem, phone is only 2 days old.

    Also, if you go to "Settings-> General-> About", it says i have "2,147,483,647" photos - In reality I have 28. Software wise, this number is the maximum a 32 bit signed integer can hold.

    I'm returning the phone to my service provider tomorrow as this is clearly DOA as far as i'm concerned. Phone is nearly stock, only other app i have installed is OneNote.
     
  6. A420Turbo macrumors member

    Joined:
    Aug 17, 2010
    Location:
    NY
    #6
    Solution

    http://forums.macrumors.com/showthread.php?p=13768352#post13768352

    (credit to gocards)

    The only thing I did different was follow what a few commenters said and only deleted the Photos.sqlite in PhotoData folder. Then rebooted the phone and went to camera roll. It said I didnt have any pictures but after 20 seconds it started restoring the photos one by one. I recommend backing up all pictures but since I only had 20 that weren't important I didn't bother. Also I lost photos that were synced from my computer but i'm sure once I resync they will all be restored.

    Never had this major of a problem on iOS4 :( I just hope it doesnt happen again my sister in law had a baby yesterday and the camera wasnt working properly. It was very fustrating.
     

Share This Page