iPhone 4s Restore Error (-1)

Discussion in 'iPhone' started by avi95nagpal, Feb 1, 2013.

  1. avi95nagpal macrumors newbie

    Feb 1, 2013
    I downloaded iOS 6.1 from a direct link and tried to restore my iPhone 4s from iTunes using (shift+restore). It was halfway complete when I got this error (-1) and my phone got stuck in recovery mode. Now whenever I connect my iPhone to my PC, iTunes show that I need to restore my iPhone but when I do I get the same error every single time. I have tried restoring on my Laptop, PC and my friend's Laptop but every time I get the same error.

    Now the main thing is my iPhone is gifted and came from another country hence it cannot be replaced here in India. :(

    Please help guys, all the help will be highly appreciated. :confused:

    Attached Files:

  2. nellyplatinum macrumors member

    Sep 19, 2012
    the only thing that seems to work for me is trying on a different computer,give that a try
  3. avi95nagpal thread starter macrumors newbie

    Feb 1, 2013
    Has this ever happened to you?
    I mean this same error -1?

Share This Page