iPhone 4S super hot and battery draining in sleep mode! Help?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Yoshi Yogurt, Sep 8, 2014.

  1. Yoshi Yogurt macrumors regular

    Joined:
    Nov 5, 2010
    #1
    So I've had this 4S which I bought from a friend in February and he got it from apple via warranty replacement in November '13. Flawless phone too

    Worked perfectly until just 4 days ago. Now for some reason the battery drains from 100% to 10% in 4 hours on sleep mode and the phone is constantly super hot. I've tried turning off all background refresh and even restored the phone.

    I've recently moved to a new area for school and I'm now roaming on T-mobile, AT&T antenna now. That's been fine for 2 weeks before this happened so that can't be the problem...

    Anyone else get this problem before?
     
  2. akhilleus macrumors member

    Joined:
    Aug 8, 2014
    #2
    My phone gets very hot when I'm running stuff like Google Maps or Spotify for awhile, but never consistently hot. I always turn stuff off when I'm done with it. Sounds like you've got a hardware problem going on. Never had it happen on my 4s (knock on wood). If you're willing, you're probably going to have to replace some parts.
     
  3. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #3
    A poor cellular signal will turn up the antenna gain on the iPhone, it'll get plenty warm.
     
  4. Yoshi Yogurt, Sep 8, 2014
    Last edited: Sep 8, 2014

    Yoshi Yogurt thread starter macrumors regular

    Joined:
    Nov 5, 2010
    #4
    Thanks for the replies, guys. If I have a hardware problem, there's now way I'm getting it fixed or getting a new phone.

    Pretty sure it isn't poor signal as I have gone roaming before without problems and I have been roaming for 2 weeks now with no issues.

    Might try to turn off data since I've already used like 45/50 Mb on the car ride/etc. and now I don't need it since wifi is everywhere. Doubt that is the issue though.

    If it is most likely a hardware issue I don't know why that would make the phone hot.

    EDIT: turning off data helped it. 2 hours pass by and the phone is still 100% where before it would be at 75%. No idea why it was freaking out but that fixed it
     
  5. Juub macrumors newbie

    Joined:
    Sep 8, 2014
    #5
    Did your phone get hot to the point it got a warning sign and shut off? Otherwise call Apple Care and have them do a diagnostic report of your battery(even better if you can go to an Apple Store).

    If your battery is worn out, it could cause all sorts of problems. Also, look inside your 30 pin connector to make sure the liquid contact indicator is not triggered. Also check the one inside the headphone jack.

    You said you've done a restore. Have you done one to factory settings without restoring your back up?

    Edit: Oh well, I hadn't read your edit. Glad you had that fixed.
     
  6. Yoshi Yogurt thread starter macrumors regular

    Joined:
    Nov 5, 2010
    #6
    That is only a temporary fix though. Might try turning on data later to check if this happens again both while roaming and normal signal.
     

Share This Page