iPhone 4S unlocked T-mobile MMS

Discussion in 'iPhone Tips, Help and Troubleshooting' started by treyjustice, Oct 24, 2012.

  1. treyjustice macrumors 65816

    treyjustice

    Joined:
    Jun 14, 2009
    Location:
    TX
    #1
    I'm having trouble getting MMS to send AND receive on a factory unlocked AT&T iPhone 4S running iOS 6 on T-mobile.

    Does anyone have setting that work for them?

    would be GREATLY appreciated!

    Thanks :D
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You will need to install the correct apn settings for tmobile usa.
    try unlockit.co.nz on your iphones safari browser.
     
  3. treyjustice thread starter macrumors 65816

    treyjustice

    Joined:
    Jun 14, 2009
    Location:
    TX
  4. Minhimalism macrumors 65816

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #5
    http://support.t-mobile.com/thread/17918?tstart=0

    This is the only way to make it 100% functional I believe? Every other time I've set the settings manually all that happens is that I can send, but not receive. Did this restore trick and my factory unlocked 5 can send and receive just fine.
     
  5. rogerbarrett macrumors regular

    Joined:
    May 22, 2012
  6. Mr Hill macrumors 6502

    Joined:
    Apr 28, 2012
    Location:
    Charlotte, NC
    #7
    No need to jailbreak. I have MMS fully working on my 4S on iOS 6 no jailbreak. Just change the settings like someone posted above.
     
  7. treyjustice thread starter macrumors 65816

    treyjustice

    Joined:
    Jun 14, 2009
    Location:
    TX
    #8
    I was able to use the settings posted above!

    MMS fail every once in a while but seem to be working mostly.

    THanks!
     

Share This Page