iPhone iPhone 4S v5.0.1 - Failing to Restore

Discussion in 'Jailbreaks and iOS Hacks' started by jandyb, Oct 26, 2012.

  1. jandyb macrumors newbie

    Joined:
    Apr 8, 2009
    #1
    Hello all.

    A short introduction: I've been a practicing member of jailbreaking since 2008 and have lots of experience overcoming issues. Except this one, I am stumped and need the help of the community.

    STORY: The other day I was doing my usual weekly Cydia updates (update all), which went fine. Later that evening, the phone died. After charging it back up, it was stuck in an infinite apple logo boot-loop. I've had these a handful of times before, on my 3GS and 4.

    I tried the "hold volume up for safe-mode" feature, but strangely it wasn't working. I then logged in via SSH with the 3 minute window (per reboot). I gathered some files off the phone. But then, something stranger happened.

    One time it rebooted, and went straight to the iTunes Recovery screen (iTunes logo with cable and arrow up). I have no idea how this happened. I never tampered with any system files.

    But now I cannot even get in with SSH to recover data or do anything else.

    ****

    PROBLEM: I am trying to restore this iPhone 4s v5.0.1 back to any 5.x (5.1.1 preferably). I have all the SHSH blobs local and remote.

    But iTunes / TinyUmbrella combo isn't working. I keep getting the "Error 1600". I've been searching google all night, and I've gathered on this board that this method isn't working anymore. (why not?)

    So I went plan B: Redsn0w Restore feature. I tell it yes 5.x to 5.x. After giving it the IPSW and it goes into uploading the files, it then comes to the error "Re-restore failed. You might have guessed the current FW incorrectly, and it may not really be iPhone4,1 etc etc.

    BUT I know that it really is that firmware. I know that 5.0.1 had 2 versions, so I downloaded both IPSW's directly from iClarified, and it still gives me this error.

    I never did an OTA (infact I installed a Cydia app to disable OTA just in case).

    Now, I'm stuck with a phone that's stuck in Recovery mode. No tools will kick it out of recovery. I can get into DFU, but not PwnDFU (4s cant do that apparently).

    Can someone please help give me some answers and/or guidance on what I should do next? Now that Apple has stopped signing all below v6.0, I don't want to restore above 5.1.1 because I cherish and depend on jailbreaking for so many things.

    Please and thanks to anyone who can help.
     

    Attached Files:

  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    First of all there has been an untethered JB for 5.1.1 for a long time, so why you don't want to restore to that 1 is beyond me.

    Make sure your host file is set to apple, type in gs.apple.com in your browser on your computer, it should take you to apple and not to Cydia.

    Download the 5.1.1 IPSW and restorw with that.
     
  3. jandyb thread starter macrumors newbie

    Joined:
    Apr 8, 2009
    #3
    First, I would love to restore to 5.1.1, but Apple isn't allowing restores to that version anymore, only 6.0. I thought this was commonplace information.

    Second, when I set the host file to Apple, I get "this phone isn't eligible for this build". But when I set the host file to Cydia, I get "Error 1600". The last part is what concerns me... why doesn't TU/Cydia restore work anymore like it used to?

    Anyone else please?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Restores of 4S do not work because they are not susceptible to the Limera1n exploit.
    If your 4S has factory fresh 5.0.1 firmware and was never updated to it's recent firmware via iTunes or your hash files were saved prior to any iTunes update, you do not qualify for the re-restore.

    Read #2

    http://blog.iphone-dev.org/post/33546509336/restoration-reinvigoration
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    It seems to me that you are not all that experienced in jailbreaking after all.

    Since the introduction of 5+ firmware restores via TU don't work anymore.
    Also the restore has to be done via the apple servers, that is common knowledge…

    So the host file has to point to Apple, otherswise the 1600 error, there are dozens of threads on this forum on that specific subject.

    You can restore to 5.x firmware under certain conditions only for the 4S.

    If you don't qualify you can't restore and are SOL

    You should have upgraded to 5.1.1 when you had the change and JB it, which is months ago.

    Check the link dhlizard gave you, it will give the conditions for the 4S restore.
     
  6. jandyb, Oct 26, 2012
    Last edited: Oct 26, 2012

    jandyb thread starter macrumors newbie

    Joined:
    Apr 8, 2009
    #6
    Well the reason I'm faced with needing to restore is because it threw itself into recovery mode for no good reason. I tried using various tools (TU, RecBoot, Redsn0w, etc) to "fix recovery" or "kick out of recovery mode" and they all just made it reboot right back into recovery again. So now the only way out seems to be a restore...

    When I first bought this iPhone 4S on eBay from a guy (back in Jan 2012), it was new with iOS v5.0.0. When I received it, the very first thing I did was plug it into iTunes and restore it to the then-current v5.0.1. I never did an OTA. I read blog #2 dhlizard but it doesn't seem to fit me. Or am I overlooking something. Because I did have my v5.0.1, v5.1, and v5.1.1 SHSH blobs saved to Cydia and inside TU *long* before this problem occurred.

    I never upgraded to the next v5.1.1 because doing so is always such a hassle getting all my JB stuff setup again. My phone was working perfectly for 10 months, until a few days ago. And I expected that if I ever did have a problem, I could do a TU restore hack, because the 3GS and 4 did that... but apparently I now learn the 4S cannot... because the TU restore hack (calling Cydia for signing instead of Apple) depends on limera1n?

    But also, even if I had already been at v5.1.1, I dont understand why I could possibly be eligible, since Apple is signing v6.0 now. I was under the impression that no matter what firmware you are at, once Apple stops signing lower numbers and jumps to the next one up, all ones below are under no conditions signable by Apple. TriJetHero, are you trying to tell me that if I had restored to v5.1.1 a couple months ago when I still could, that even if this tragedy happened to my 4S, and Apple is signing v6.0, I could still be eligible for a v5.1.1 restore via Apple?

    So... is there *anything* else I can do to stay at v5.x? Or am I totally SOL and must upgrade to v6.0... and just wait with faith that it gets jailbroken someday...

    Thanks for the answers guys.

    PS- Isn't the Redsn0w restore method supposed to be a last-resort fix. So why isn't it working for me, when that error message screenshot above shows I'm not at v5.0.1, when I know I am.
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    Most of it is correct.

    The whole process of signing a firmware changed going to 5+ so it doesn't have anything to do with limera1n.

    Ofcourse you can jump to a lower one, that is what your SHSH/APTicket combo is for!!

    A4 devices like the IP4 it is easier because of limera1n.
    For a while all devices could downgrade as long as they had there blobs.

    After the 6.0 release it changed again, until the new redsn0w came out the 4S could not downgradde or re-restore to current firmware.

    No under certain conditions you can re-restore, if you are on 6.0 than you are stuck anyway.

    Redsn0w is not the last resort it is the main JB/restore tool.

    Did you verify that you have full blobs with redsn0w including the APticket?
    Go to Extras/SHSH/verify and use your local saved SHSH
     
  8. dxdiadora macrumors newbie

    Joined:
    Nov 11, 2012
    #8
    more or less, i tryed all the methods you did, and still i got the same problem!
    have you succeeded on re restoring? cuz im trying everything possible but no luck :/...

    anybody else can help? thank's in advance i would really appreciate any help!
    (ipad 3,3 5.1.1 stuck on bootloop, can recovery/dfu, i got shsh blobs)
     
  9. jandyb thread starter macrumors newbie

    Joined:
    Apr 8, 2009
    #9
    No solution for me yet

    I haven't fixed the problem yet. I had an iPhone4 as a backup which I've been using, I just shoved the iPhone4S into a drawer because it became too frustrating.

    I dont want to restore up to v6.0.1 yet because there may not ever be a jailbreak for it, and even if there is, it may take a short or (most likely) long while. Anyone remember the iPad 2 jailbreak waiting time?

    However I also don't think I'm going to find a solution on my own. I'm keeping the 4S in its current state in case someone else is a blessed soul and posts an answer that fixes my problem.

    I'm willing to try anything anyone has to offer though. I just want to restore my 4S v5.0.1 to v5.0.1 again (or v5.1.1). But iTunes gives me the "error 1600" when I try to use TinyUmbrella (apparently because the 4S is different?) I have blobs for all 5.x. Redsn0w wont do a custom IPSW restore either because it tells me the error I posted earlier.

    Le sigh...
     

Share This Page