iPhone 4S Volume Buttons

x-ray-cat

macrumors newbie
Original poster
Nov 24, 2011
6
0
I've had my (unlocked) 4S for a month now, and all of a sudden I got this problem - the volume buttons (+/-) on the left side only works when I have headphones plugged into it, and applications do not play sounds on notifications etc - but when someone calls / I get a message it plays sound. On Sleep Cycle and Spotify it says "No volume available"

(and no the iPhone is not muted).

I took it to an a store (not an Apple Store, as we don't have them in Norway) and he basically told me the buttons were broke because of moist - but why would they then be working when I use headphones? The volume buttons not working is not my biggest problem - my biggest concern is that apps dont play sounds, not on notifications either. Lock sounds etc do not work as well.

What to do?
 

miss.manson

macrumors 6502a
Dec 12, 2011
764
30
Georgia
I've had my (unlocked) 4S for a month now, and all of a sudden I got this problem - the volume buttons (+/-) on the left side only works when I have headphones plugged into it, and applications do not play sounds on notifications etc - but when someone calls / I get a message it plays sound. On Sleep Cycle and Spotify it says "No volume available"

(and no the iPhone is not muted).

I took it to an a store (not an Apple Store, as we don't have them in Norway) and he basically told me the buttons were broke because of moist - but why would they then be working when I use headphones? The volume buttons not working is not my biggest problem - my biggest concern is that apps dont play sounds, not on notifications either. Lock sounds etc do not work as well.

What to do?
Go to Settings>General>About>Diagnostics and Usage>Diagnostic And Usage Data
Look to see if there are any panic.plist in your directory. If there are it is probably a hardware defect..
 
Comment

x-ray-cat

macrumors newbie
Original poster
Nov 24, 2011
6
0
Go to Settings>General>About>Diagnostics and Usage>Diagnostic And Usage Data
Look to see if there are any panic.plist in your directory. If there are it is probably a hardware defect..
Nothing there :S

I took it to the store, I could get a replacement for around 200 dollars (in NOK) - so If I can't solve it I'm just doing that then - bleh
 
Comment

x-ray-cat

macrumors newbie
Original poster
Nov 24, 2011
6
0
Yey! Went into the store one more time, another employee at the service desk today - he just sent it in without questions! New one arriving in a few days :)
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.