iPhone 4S volume buttons...

bubulindo

macrumors member
Original poster
Jul 16, 2010
62
0
Neither here, nor there...
Hello,

First of all, yes I have looked at the forums and have found people with similar problems, but none actually got a good reply.

A few days ago I noticed that my iPhones hardware volume buttons work perfectly when I have my headphones on, however, when I get them off, the buttons stop working and whenever I push any of them, I only get the overlay logo of the speaker/ringer but no bar is showed on the bottom.

If I start the Music application, the same happens, no volume control is displayed and if I swipe on the taskbar twice to the left, the control isn't there either.

It's clearly not a button hardware fault since I can use them with the headphones on, it's not a speaker problem because I get my calls ringing the speakers, so what could be?

Any of you guys has had this issue before?

Thanks in advance for any help that you can provide.
 

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,606
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Restart your phone. (power&home together)
 
Comment

bubulindo

macrumors member
Original poster
Jul 16, 2010
62
0
Neither here, nor there...
If you already tried a reset, you might want to take it to the genius bar
This is weird...

I restored it as new yesterday, and it still showed the same symptom. Since I wanted to make sure that I would receive calls, I ringed it just to verify that it would still ring.
After that I tried the button and it worked.

Now, in the morning, when I woke up, the buttons wouldn't work anymore. It's definitely a software issue. A really freaky one too. :\
 
Comment

robjulo

macrumors 65816
Jul 16, 2010
1,347
2,255
This is weird...

I restored it as new yesterday, and it still showed the same symptom. Since I wanted to make sure that I would receive calls, I ringed it just to verify that it would still ring.
After that I tried the button and it worked.

Now, in the morning, when I woke up, the buttons wouldn't work anymore. It's definitely a software issue. A really freaky one too. :\
Did you ever get a resolution, I'm having the same issue.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.