iPhone 4s wifi connectivity problem

Discussion in 'iPhone' started by hibanzai, Oct 15, 2011.

  1. hibanzai macrumors member

    Joined:
    Jul 24, 2011
    #1
    I see my home wifi network, I choose it, and I enter the password then press join. All I get after that is a circle next to the name of my network as if connecting or loading (this stays like so forever, as if not really connected, just connecting), when I go back to the main settings page I see next to wfi the name of the network, but nothing near the carrier signal bar. Also when I try to download a large-ish app from app store, it still asks me to connect to a wifi network or conect via iTunes to download said app. Which means it's not connected to the network.

    How do I fix this?

    Also, is there a way to download a large app without having to connect to wifi? I have unlimited data :cool:
     
  2. yanki01 macrumors 68040

    yanki01

    Joined:
    Feb 28, 2009
    Location:
    Texas
    #2
    anything over 20MB needs to be downloaded either by wifi or iTunes via a computer.

    are there any other devices hooked up to the wifi? if not have you turned off the router or reset it?
     
  3. zjazz macrumors 6502

    Joined:
    Apr 7, 2011
    #3
    I have same problem with wifi at home on my 4s!!!! It would spin like connecting and nothing happens. First I thought something wrong with new phone, as all other devices work ok, but later went out and tried several free wifi outside and it worked perfect...so im guessing some incompatibility with my router. I have linksys model wrt54g. OP what is your router? Is there anyone else have problems with their linksys?
     
  4. hibanzai thread starter macrumors member

    Joined:
    Jul 24, 2011
    #4
    yeah, I think I connected fine on another network last night. It seems to be my home router only for the time being.

    My router is a Trendnet TEW-452BRP

    I used to connect my blackberry fine on this router though, as well as a Nokia Symbian dinosaur.
     
  5. drew077 macrumors member

    Joined:
    May 22, 2008
    #5
    I might have a fix.

    Hello, I had this same exact issue with my iPhone 4S. I think it might have to do with restoring from back up or something, but anyways what seemed to work for me was resetting the Network Setting. Just go to general->reset->then select reset network setting. This should work, let me know how things go.
     
  6. Hutch1 macrumors 6502a

    Hutch1

    Joined:
    Jul 24, 2008
    Location:
    Guelph, ON
    #6
    You don't have MAC filtering on by chance in your routers security settings do you?
     
  7. zjazz macrumors 6502

    Joined:
    Apr 7, 2011
    #7
    >drew077, thank you!!!:):):) I did the reset of network setting and now my wifi working! super! :):):)
     
  8. hibanzai thread starter macrumors member

    Joined:
    Jul 24, 2011
    #8
    mac filtering is disabled.

    I reset the network settings, when I tried to join my network it first gave me the message unable to join (name of network), I hit dismiss, then I tried again and now back to square one. spinning circle and not really connecting to anything.
     
  9. Eko99 macrumors newbie

    Joined:
    Oct 17, 2011
    #9
    same issue

    i have the exact same issue with my iPhone 4s. still haven't found a solution yet. i tried pretty much everything from hard/soft resets on both devices. I have the latest airport extreme base station. all my other apple products (iMac, mbp, iPad 2) works perfectly. if you find fix for this please post it. i'd really appreciate it.
     
  10. hibanzai thread starter macrumors member

    Joined:
    Jul 24, 2011
    #10
    Reset the modem and router today, and without really noticing the phone simply connected without any fuss.
     

Share This Page