iphone 4s - wifi not working at all.

Discussion in 'iPhone' started by h2009, Oct 22, 2011.

  1. h2009 macrumors member

    Oct 13, 2007
    Hi there,
    I've got a strange issue and I believe its a bug or faulty iPhone hardware but it seems I cannot connect to any wifi network that uses WPA/WPA2
    What I mean is that the wifi connects to any AP but for some reason external addresses like google.com do not work. All internal address do.

    Its not a network issue as every other IOS5 device works fine and the network has no problems. Its something to do with iPhone 4s.
  2. diamornte macrumors regular

    Apr 27, 2009
    I am having wifi issues as well. Using an Apple Time Capsule with 2.4 Ghz wireless N only settings. Speed test app shows a healthy download speed until less than halfway into it, the connection chokes to nothing. Did hard resets on the iPhone 4S and disabled iCloud but I still cannot connect. Disabling wireless and using 3G only is the only solution. Why is this happening?
  3. Macman45 macrumors G5


    Jul 29, 2011
    Somewhere Back In The Long Ago
    Refresh Your Network Settingts

    Settings / general network....
  4. h2009 thread starter macrumors member

    Oct 13, 2007
    Tried that already, one of the first things.

    There is something wrong with the software I'm sure. Isn't anyone else having WPA issues?
  5. Dangerous Theory macrumors 68000

    Jul 28, 2011
  6. h2009 thread starter macrumors member

    Oct 13, 2007
    Yes its been reset.
    Factory restored
    Profile restored.
    Multi AP's tested across different manufactures
    The only thing which works is open networks or WEP.
  7. Rapickering macrumors newbie

    Feb 17, 2010
    Iphone 4S wifi & bluetooth not working

    This may seem strange and I'm sure Apple would never suggest or promote this but...switch your phone off. Point a hairdryer at it on medium to high heat for between 3 and 6 minutes. Allow to cool and then power phone on again. This worked for me. Previously, both the wifi and bluetooth buttons were greyed out in settings, they now work perfectly! I believe it has something to do with the wifi/bluetooth chip ceasing to work and the heat gets it going again.

Share This Page