iPhone 4s wifi performance problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by googull, Oct 16, 2011.

  1. googull macrumors newbie

    googull

    Joined:
    Jul 11, 2007
    #1
    I decided to measure the preceptively slow wifi performance on the 4s. This after a hard reset on the network settings, shutting off the cellular signal, closing all background apps, disabling Push and all iCloud services services except "Find my iPhone". Using the speedtest.net iOS app all devices set to same server (Seattle, WA) I ran the test 5 times on each device with the others shut off. Here are the averaged results:

    iPhone 4s.
    4.04 Mbps download and 2.06 Mbps upload

    IPhone 4 (iOs5) with cell signal active
    13.19 Mbps download and 4.74 Mbps upload

    iPad2 (iOS5) wifi only
    20.6 Mbps download and 4.93 Mbps upload

    Consistent results from the 4 and iPad2. Lots of variability from the 4s and never anything close to the others.

    Also noted that uploads from the 4s sometimes hang resulting in server disconnects. For example I uploaded a collection of photos to Zenfolio last night and had to restart the upload six time due to timeouts. The same upload from the iPad was extremely fast and uninterrupted.

    4s results seem to be very sensitive to placement. Slight rotation or movement a few inches can have significant impact. No such sensitivity noted on the 4 or iPad2. Otherwise the only caveat I have not tweaked is wifi channel on Netgear router. It is currently set at 11 and has performed beautifully for years. Perhaps 4s would do better on the crowded channel 6.

    I am interested to hear what others are finding or insight on something I may have missed.

    Carl
     
  2. tann macrumors 68000

    Joined:
    Apr 15, 2010
    Location:
    Nottingham, England
    #2
    I have no idea what's wrong with mine, but earlier it was fine, over the past 5 or 6 hours it's been SLOW. Speed tests average 0.7 down. Tried my iPod touch 2nd gen and I got 7down on that. My Mac has also been going SLOW. So slow it cannot even load web pages.

    Every other computer (and as I mentioned before my old iPod) can connect to it fine and are running full speed.
     
  3. bdogggut34 macrumors newbie

    Joined:
    Jul 20, 2011
    #3
    I just posted another thread similar, i have 12 Mbps service and on the Macbook i get 11.3 Mbps but Iphone 4S 6.2 Mbps. Wondering if this is an issue as well same as yours.
     
  4. CrAkD macrumors 68040

    CrAkD

    Joined:
    Feb 15, 2010
    Location:
    Boston, MA
    #4
    My iPad 2 gets 35mbps down on my time capsule. My 4s gets .01mbps down. However if I enable wifi on my fios router my 4s gets like 14mbps down......what the hell.
     
  5. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #5
    Is your ipad2 attached to the 2.4GHz or 5GHz side of the Time Capsule? The 4S only hits the 2.4GHz side, so you might look to resetting the TC since your 4S gets good results on the fios router
     
  6. CrAkD macrumors 68040

    CrAkD

    Joined:
    Feb 15, 2010
    Location:
    Boston, MA
    #6
    iPad is 5ghz.........I'll try resetting.
     
  7. kieron121 macrumors newbie

    Joined:
    Oct 12, 2011
    #7
    So has it been determined to be an iPhone 4s hardware problem? As I'm experiencing the same problem, and I am going to wait to try everything else before I return the phone as I got it from apples website
     
  8. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #8
    Since many people have no problems at all with wifi, or whose problems go away after resetting network settings or the router, I highly doubt there is any endemic problem with 4S hardware. Certainly there may be individual units suffering from a hardware problem, but it's clearly not universal.

    Here's from a couple minutes ago, cable internet rated at 15M down 3M up. Computer (MBA) got 20.29 / 3.37 immediately after.

    My point is the 4S hardware is certainly capable. My 4 never hit this high, achieving maybe 75% of this rate. Router is Netgear WNDR3700, 4S is on the 2.4GHz side, MBA on the 5GHz side.
     

    Attached Files:

Share This Page