iPhone 4S won't restore to 8.1.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by davidly, Dec 2, 2014.

  1. davidly macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #1
    Hi guys, I'm new here even though I've been reading for a while now.

    So here is my problem. I've bought a used iPhone 4S that had the 'Connect to iTunes' logo on it. The previous owner did an update (probably to 8.1 or 8.1.1) that did not complete somehow, I don't have the details but I bought it cause it was cheap and that I'm used to fix phones and computers.

    However, for this one I'm quite stuck.
    I first plugged the phone and tried to restore to 8.1.1 with the latest iTunes, but I got the 4014 error.
    Every time I retried, I ended up on the same 'Connect to iTunes' logo, and if I did a hard reset at that stage, I could still see the Apple logo, then the phone would eventually reboot itself forever.

    Then I tried to put the phone in DFU mode (redsn0w confirmed it was well in DFU) and do the restore. That time I got a 4013 and sometimes a 2002 error.

    Now the screen won't turn on, even if I charge the phone, and even if I do a hard reset and then plug it to the wall charger. I tried to keep the phone charging and then do the hard reset but still nothing shows on the screen.

    I can still go on DFU mode, but not on recovery anymore. Nothing shows on the screen neither on iTunes nor redsn0w (while I could see iPhone in recovery at the beginning).
    Then I tried my luck, I tried to restore once again but no success, and a new error : 4005.

    What could be possibly happening? A faulty dock connector? A bad battery? Or a bad download? I downloaded the .ipsw file for iOS 8.1.1 which I used on iTunes to do the restore.

    I want to add that when I click on restore, iTunes stays on 'Waiting for iPhone' for a long time, then I hear the device detection sound, then it disconnects, then the phone screen turns on (with no Apple logo) and finally shuts down after 2 or 3 seconds. Then I wait for 2 or 3 minutes on iTunes and I get the 4005 error.

    Also, is the battery charging in DFU mode? Some people say yes, others say no... If it's not charging, I guess I will have to put it out and charge it with a USB cable?

    Anyway, thanks for taking the time to read me, sorry for the long text but I needed to be accurate. Now hoping to have a solution :)
     
  2. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #2
    After letting it charged all night long, I'm now at the 'Connect to iTunes' logo but when I try to restore, i get a new error again : 21.
    Same on DFU mode but this time I'm able to get back to simple recovery mode after the restore fails, while I was previously stuck at a black screen (not the DFU mode of course).

    So after all I guess it charged on DFU mode but I'm still stuck unable to restore.
    Some guys on iFixit said it may be a battery connection problem...
     
  3. XoioX macrumors newbie

    Joined:
    Dec 3, 2014
    #3
    Hi davidly,

    Interestingly enough I am going through exactly the same process with an iphone 5.

    Only difference is I have managed to get it to show the start of a progress bar under the apple logo but then it got stuck there. This only happened when I used a brand new USB cable and tried on a different computer and again with a different USB port. THere is definetly something fishy with the way the USB is handled.

    I have checked the serial number of the phone on the apple website and found out the phone had been replaced when still in warranty so I wonder what happens to iphone which have been replaced in such circumstances: As clearly itunes connects to an apple server before restoring the target, if the serial number is identified as having been already "dealt with", does this mean the phone is now as good as a brick?

    Also when I connect this iphone with itune (either in recovery of DFU mode) the serial number appears as n/a in the window. Does yours show the same?
     
  4. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #4
    Hi XoioX,

    Yes my iPhone shows as n/a under iTunes.

    However today I did spend some more time on it, and I'm pretty sure it's a hardware problem. The phone didn't charge overnight (or I think it didn't) but anyway after plugging the battery out, I discovered that the phone still turns on! I really did have no idea about that before today so I'm quite confused, I don't know if it's a good or a bad news...

    So with or without the battery, I get error 21 anyway, cause the phone searches for the battery after the Apply logo shows up, and since there is none, it simply turns off and goes back to recovery mode.

    The new problem is that I'm unsure if it's a problem with the battery, the battery connector, the dock connector, or even worst, the power IC... The last case would terribly sucks because I'm not qualified to repair it.

    I can change the battery or the dock connector without any hassle, I can try to solder the battery connector but the power IC is too hard for me and I don't know any reliable (and cheap) professional in my area.

    I'm getting a new battery tomorrow, I will then update the thread if I have new information or questions.
    Btw, do you know if the phone charges the battery in recovery or DFU mode? Assuming that there is no hardware issue, that is.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Please do a "cat /etc/hosts" in Terminal and post the results back here.

    Explanation: I *think* 4005 is the number you get if iTunes can't access gs.apple.com, and the most likely cause is that some "jailbreaking" software has tampered with your hosts file.
     
  6. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #6
    Thanks for the answer.
    My host file is default so I don't think it was coming from there.

    Code:
    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
    # localhost name resolution is handle within DNS itself.
    #       127.0.0.1       localhost
    #       ::1             localhost
    I don't have the 4005 error anymore at the moment, I'm more worried about a battery/charging defect. Do you know if the battery charges up in recovery mode?
     
  7. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #7
    Ah, you're using Windows! I have no idea what to do next as I've never used an iPhone with Windows. I would *imagine* that it'll charge, although it will likely be faster to use a wall charger instead of a computer.
     
  8. XoioX macrumors newbie

    Joined:
    Dec 3, 2014
    #8
    Hi Davidly,

    Interesting yours also shows n/a in serial number. Do you know if that phone was replaced under warranty by the original owner?

    I think the 4005 error is a none-issue: this is easily resolved and it has no further effect on the restore process afterwards: Depending on which windows version you use to try to restore the phone you get additional info at each step: I used an old laptop with XP 32 bits and you get a better description of each steps (which are hidden in win 7).

    So for example, a window pops up when you conect the iphone while itune is connected and tells you it is connecting to the server to carry out the check: this is before it tells you the phone needs to be restored. If for any reason whatsoever it cannot connect it tells you straight at that point (and you cannot proceed with the restore). This is using itune 12 on win XP.

    One bonus with XP is when you try to restore and the phone connects/disconnects/reconnects it tells you exactly which drivers are being used every time: for example iphone in receovery mode or even iphone in DFU mode or simple iphone.

    What is strange is that I got different results when i used a brand new usb cable i bought this morning (proper apple cable) although the one I was using prior to that was the one from the original iphone box.

    When I first got the phone, the battery was completely discharged and I plugged it in with the AC adapter before I started trying to fix it: The empty battery with the red line was showing after a few minutes and eventually became green much later on. Since I have been trying to restore it, it is constantly plugged in a usb port or another so I dont believe it is discharging. Like you I cannot check the amount of charge in the battery as you normally need IOS to be up and running to get that info displayed.

    Interesting you can still turn it on with the main battery removed. This obviously means there is a small cell battery on the PCB. I wonder if removing that one would completely reset the phone and allow for an easier restore. Although any info in the flash would remain.

    Regarding replacing the power IC: Sounds like an expensive solution which you would need to be pretty damn sure it is the faulty party before going ahead with that. My thinking is that if you are able to see the logo on the screen or the itune logo (in recovery mode), there is enough juice to power up. This is something to investigate once you got it back up and running if you feel it is not keeping the charge for long enough.

    I am convinced the key to crack this is with the USB: Getting the killer combination of the right windows version (clean install maybe), itune, usb drivers, PC ports, cable and phone
     
  9. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #9
    @Nermal : even if I plug in the wall charger, I still get no charging indicator. In fact, the phone just tries to boot normally, so I see the Apple logo and the bootloop. Same if I charge it on the laptop. Do you know if the normal charging mode (from a powered-off state) is triggered even in my condition? Or does it trigger only with a proper firmware installed (in other words, not in my bootloop situation)?

    @XoioX : I have no idea if the phone was previously serviced by Apple, but the last service was not done by Apple because I found the 2 screws missing on the battery connector... Maybe it was just a non-genuine battery, hence all the problems. I'll know more tomorrow as the battery I ordered will arrive.

    Interesting that XP shows more details, but unfortunately I can't easily install it because my laptop is Sata. I know there is a version with Sata drivers loaded up but I don't know if I will have more luck with that.
    I've tried 7 32 bits and 8.1 64 bits Windows(my current install).

    Did you get any progress on your side? Do you get the charging indicator when you plug it on the wall charger?
    Are you stuck on the Apple logo when you just plug it without pressing any button?
     
  10. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #10
    Some news...

    Installed the new battery, the phone turns on and keeps on the iTunes logo even without being plugged. That's for the good news.

    The bad news is that I get an error 4013.
    To be more accurate, after I click on restore, I get the 'wait for iPhone' message, then the phone normally restarts as with an usual restore, I get the Apple logo and the loading indicator but after 3 or 4 seconds it turns off, and I get back into recovery mode.

    Is it the dock connector that gives this error?
     
  11. XoioX macrumors newbie

    Joined:
    Dec 3, 2014
    #11
    Hi Davidly,

    I think once you go into the 4013/4014 path, all the posts I find relate to a "hardware" fault, whatever this means:

    If you go by this thread
    http://support.apple.com/en-gb/HT201444
    The help is very VERY generic to say the least and basically not helpful at all.

    Now if you follow the link on that page which says "contact apple support", following through at some point you will find a page where you have to put in the serial number of your iphone: I would be curious if you do that what message you get back?

    For my iphone 5, it says something along the lines of "the phone you are seeking support on has already been replaced as part of warranty", so cutting it short I cannot seek help from Apple and proceed further.

    Hence my worry that eventually, when iTunes connects to the server prior to restoring the iPhone, whether it determines this is a no longer supported phone and will not do the job no matter what. There is however the fact that, in both our cases, the serial number is not reported in iTune to start with... Could that also be a clue...

    So back to the 4013 error: everything I have seen so far seems to point at a USB issue: As soon as I plug the phone more than once in the same USB port (with the view of restoring it) it starts to hang and behave differently during the restore process the 2nd time round ending up after waiting a few minutes in a 4013 or 4014 error.

    There is a good description here
    http://www.jailbreaktrend.com/fix-itunes-error-4013-4014/
    which may help you but on my side none of these tips have worked yet.

    This is where I believe this is not a "fault" as such but a compatibility issue between Windows version, PC ports and crazily enough the USB cable itself.
    This in turn has to be matched to the iTunes version you are using and the iOS version you are trying to restore.

    I wish I had access to a low level USB monitoring software which would details the exchange between the iPhone and iTune as it would help to identify where it hangs and maybe force it to carry on to the next step.

    Twice I got the progress bar started under the apple logo but it hung afterwards. (Used DFU mode and plugged in on old XP machine updated to iTunes 12 and trying to force/restore (using shift when clicking on restore) to select iOS 8.1.1. But could not get back on the same port afterwards.

    I am looking now at how to clear all the settings on a USB ports before trying again. Win 7 and Win 8 machines have not helped so far so abandonned with those Windows versions for now. I wish I could try with a MAC but ain't got one...
     
  12. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #12
    Hi XoioX,

    Here is what I get from the serial check : [​IMG]

    I really don't know about Windows versions, I tried on Windows 7 and 8 again and still no luck. I also don't have access to a Mac, unfortunately.

    Tomorrow I will hand the phone to a friend who works in a repair service, I'll tell him to try with a new dock connector and I'll update the post :)

    As for your iPhone, I don't think that it's prevented from restoring because it's not supported anymore. As far as I know Apple doesn't do this.
    The serial showing as n/a may be normal as iOS is not in a normal state. I had many iPod Touch and under recovery they never showed their serial number.

    Did you buy yours in a bricked state too?
     
  13. XoioX, Dec 4, 2014
    Last edited: Dec 4, 2014

    XoioX macrumors newbie

    Joined:
    Dec 3, 2014
    #13
    Hi Davidly,

    Ok tried to do the same check with mine (used this link:
    https://selfsolve.apple.com/agreementWarrantyDynamic.do
    and got:

    Apple.JPG
    (sorry pic is so small - you can click on it and it will show message clearer)


    Yeap bought the iPhone 5 in a bricked state.

    Thanks for the info on the n/a in a recovery mode. I'll try more combinations later and update if I get anything.
     
  14. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #14
    After using your link, I still get the same result as you saw on the screenshot.

    I tried one more time before giving up for today, and I could snapshot something strange in iTunes. When it's extracting the firmware, I have one iPhone detected :

    [​IMG]

    But when it prepares the phone, I get this :

    [​IMG]

    I can't click it as it disappears very fast, like in less than one second.

    Do you have the same case?
     
  15. XoioX macrumors newbie

    Joined:
    Dec 3, 2014
    #15
    Hi Davidly,

    I have tried several times now but I cannot see the same thing (ie mine only shows 1 iPhone at the top).

    Tried with:
    XP / itune12
    XP / itune10
    Win 7 / itune12
    WIn 8.1 / itune12
     
  16. davidly thread starter macrumors newbie

    davidly

    Joined:
    Dec 2, 2014
    #16
    Hi XoioX,

    I cannot say it's nothing, maybe it's really a hint to the problem but as you said we don't have low level monitoring available...

    I'll let you know once the repair shop send me news :)
     

Share This Page