Resolved iPhone 5 3G Internet - Sees but doesn't load pages?

Discussion in 'iPhone' started by Sheza, Sep 25, 2012.

  1. Sheza, Sep 25, 2012
    Last edited: Sep 25, 2012

    Sheza macrumors 68000


    Aug 14, 2010
    Cambridge, UK

    I'm about to ring up Three and ask them about this but I have a funny feeling they won't be of much help.

    I activated my iPhone 5 yesterday and put in my Three Nano-SIM on a SIM-Only contract that had started on Saturday. The phone recognised the network and displayed a few bars of 3G signal in my house. I registered to MyThree via the website because the app said I wasn't recognised to be on the Three network. It displays my allowances etc just fine.

    I can receive and send calls and texts, and can load pages through WiFi just as usual. However disable WiFi or leave the house, and no matter how good my 3G signal is, it refuses to load any webpages or basically anything that requires the internet.

    Is there some part of the activation process I forgot to do or something? Any help appreciated.

    On a side note, notifications for things like Twitter and facebook worked brilliantly on my iPhone 4 but for some reason will not work at all on my iPhone 5. I've checked and they're turned on in the notification center...

  2. johnothy macrumors regular


    Mar 10, 2012

    Which carrier are you on? I'm on Verizon. I've been having issues where loading a web page just hangs and takes forever to bring up the page, or doesn't at all. I've turned off 4G LTE to see if it helps on the battery today and now the phone seems to remain on 2G (circle logo at the top).
  3. Dwalls90 macrumors 601


    Feb 5, 2009
    We had a similar issue with one on my family's account. Basically, when the 5 was activated, AT&T was too stupid to just update the plan accordingly, thus the data plan was never activated.

    That's the issue you are having - the phone functionality works, but you have no valid data plan activated. I would contact them and have them activate an appropriate data plan.
  4. TableSyrup macrumors 6502

    May 29, 2012
    Do you have Cellular Data turned on under General Settings / Cellular?
    Also, roaming data??

    Have you downloaded and ran SpeedTest???

    Couple other things to try:

    General / Reset / Reset Data Network

    If that doesn't help, load your phone dialer, and dial:

    then press CALL
  5. Sheza thread starter macrumors 68000


    Aug 14, 2010
    Cambridge, UK
    I'm on Three. It's a UK carrier.

    The person on the phone said he has to speak to the actual account holder after he ran me through some trouble shooting steps. Sigh. I have to wait a good hour for him to be free.

    Cellular Data is on
    Roaming is off
    I ran SpeedTest. On WiFi it worked fine, on 3G it hung on "finding best server".

    I was not advised by the man on the phone to reset the data network, amazingly.

    What does the dialler do?
  6. ekg0477 macrumors newbie

    Oct 17, 2011

    This fix worked for me. It seems to be a wide spread problem.

    First back up the phone if you do not already have a back up.

    Reset to factory settings.

    Try again for data, this should work.
  7. Sheza thread starter macrumors 68000


    Aug 14, 2010
    Cambridge, UK
    Well basically the Three support was completely useless, they claimed it was a problem with a network first, then a SIM card, then the phone! What's up with that?

    I will try the few things mentioned here.

    EDIT: And will you look at that, resetting Network settings worked fine. Hahah! What a waste of my time on the phone. I can't believe they asked "Do you know of any friend or relative that also has an iPhone 5 on Three that would be able to test?"
  8. x32fzw macrumors newbie

    Sep 29, 2012
    Trying to find the answer to this very question - Three support just blame the iPhone and say to ring Apple Care.

    I joined three last week with a unlocked 5 and since then I can't get internet over 3G - exactly the same as the OP. I can make calls, send texts but no browsing etc.

    Resetting my Network Settings temporarily fixes the issue but as soon as I leave my phone for a while and come back it can't connect again (despite full 3G signal). I travel around a bit and this applies everywhere so it's not the masts nearby.

    I've found - weirdly, as it shouldn't make any difference - that turning Data Roaming On then Off in Cellular gets me back online. So, maybe a Three network authentication issue? Apparently all my settings have been "provisioned" and should work. Humph. :(
  9. piprensare macrumors newbie

    Sep 30, 2012
    Same problem, Telstra Australia

    My two cents:

    I'm with Telstra Australia and has the same problem with my iPhone 5, and the resetting of network settings worked (settings>general>reset>reset network settings).

    I did also have a frustrating phonecall with Telstra support where they "refreshed my settings" from their end, but I highly doubt that was the fix.

    Hope that helps someone!
  10. yoyodub macrumors newbie

    Sep 21, 2012

    same issue here. bot an unlocked 'phone from apple, bot a PAYG nano sim from Three, everything works except the internet. After pulling teeth on the 'phone support, I went into a shop and after the charming sales attendant had a fight with the 'phone support, walked out with a new nano sim. Still no internet though!!! Glad I'm not on a contract with any of these mobile 'phone companies: they all have an atrocious approach to customer service. :mad:
  11. Nahla macrumors newbie

    Nov 24, 2012
    I can obtain and also send calls and also texts, and can weight pages thru WiFi equally usual. However disable WiFi or perhaps allow our home, and also no matter how good my 3G alert is, it refuses to load any webpages or largely anything that requires the internet.
  12. yeah macrumors 6502a


    Jul 12, 2011
    That's not 2G, that's 1XRRT or EV-DO I believe.
  13. raj1214, Dec 15, 2012
    Last edited: Dec 15, 2012

    raj1214 macrumors newbie

    Dec 15, 2012
    True That

    Windows 8 totally sucks. With No Support for graphics, sound and miscellaneous devices' (printers, scanners etc.) drivers and/or support available at the moment i seriously don't think opting for the eye-candy that windows 8 offers (i mean over hyped Modern GUI) is worth it.

    overall, windows 8 is just a can of trash.
  14. gakgurk macrumors newbie

    Jan 2, 2013
    hi and thanks from turkey.
    i had the same problem with the local GSM operator Turkcell. tried 'Settings>General>Reset>Reset Network Settings' . this solved the problem for the moment.
    I suggest but not sure! that a restore from my old iphone might have caused the problem. Anyway hope it does not appear again.
  15. JimmyD1977 macrumors newbie

    Mar 26, 2013
    'Settings>General>Reset>Reset Network Settings'

    Hi all, many thanks - this worked for me too:

    'Settings>General>Reset>Reset Network Settings'

    I'm on 3 also. Currently in Rotherham and will travel back home 35 miles this afternoon.

    Will report any problems if they happen but very happy with the info you have provided.

    Thanks again!:)

Share This Page