iPhone 5-after replacing charging port home & power buttons don't work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ryst, Feb 6, 2014.

  1. ryst macrumors newbie

    Joined:
    Feb 6, 2014
    #1
    Hi guys,
    Helping a friend out by replacing his charging port on his iPhone 5. Followed the guide and all seemed to go smoothly, went to power up and still no problems.
    However, the power and home buttons now don't work.

    I set about disassembling it again, and now it's stuck on recovery mode, currently waiting on the ipsw to download to get it into DFU mode via redsn0w so that should, be okay, hopefully.

    Anyways, any comments or opinions would be greatly appreciated as I'd like to get this guys phone back to him as soon as possible.
    Cheers
     
  2. artursr1985 macrumors newbie

    Joined:
    Feb 6, 2014
    #2
    when you torn on usb cabel and you see on your iphone apple logo put off the cable and wait, and your iphone turned on. sorry abaut my english :) i hope you understand
     
  3. Charadis macrumors 6502a

    Joined:
    Jul 3, 2010
    #3
    I'm not sure how this could be. The sleep/power button is on a separate flex cable from the Home button assembly and attaches directly to the main board on the upper end. The Home button assembly is attached directly to the display assembly and connects to the charger/speaker end of the phone, which I assume is what you were working on.

    Did you attach that small little attachment for the flex cable onto the motherboard? If the volume/sleep-power/vibrator buttons do not report when you press any of them, then you may need to open the phone back up to connect this cable. I can understand how it can be easily overlooked and subside underneath the main board while reassembling.

    As for the Home button, make sure the contacts on display are meeting with the contacts on the bottom board; this should be on the left side of where the Home button would be. The display would have to be refitted back into the phone case, or partially fitted from the bottom, in order to test (if you still have not reassembled it, then the Home button would definitely not work). Let me know if this solved any of your problems. Sent from my MacBook.
     

Share This Page