iPhone 5 -- apps won't update OTA

Discussion in 'iOS 10' started by zorinlynx, Mar 6, 2017.

  1. zorinlynx macrumors 603

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #1
    Hello folks. Was wondering if anyone could provide some insight.

    Girlfriend has an iPhone 5 on iOS 10.2.1, and her apps mysteriously stopped updating a few days ago. When you go into the App store and hit the update button, the button becomes the "square with a circle" updating icon, but it doesn't update. Nothing downloads, it just stays like this forever. This is the case with all apps, and it's not the network because my phone and iPad on the same WiFi update just fine.

    Things I've already tried:

    - Rebooting the phone
    - Logging out of the app store and back in
    - Deleting a few of the apps that aren't updating
    - Reset Network settings
    - Reset all settings

    I can install and update her apps using iTunes, but obviously that's inconvenient. I'm getting close to the point where I'm going to restore the phone, but before I go through that I wanted to see if anyone has had this issue and solved it in a less drastic way.
     
  2. jr866gooner macrumors 65816

    jr866gooner

    Joined:
    Aug 24, 2013
    #2
    Any chance these apps were downloaded under a different id? I messed up and had two ids for a brief period and made two purchases under the id I didn't really want to keep so to avoid having to buy those two apps again under my main account I simply logged out and in to install them logged out and in finally with the account I wanted...
     
  3. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #3
    I have an iPhone 7 Plus and I haven't been able to install a single update since yesterday.
     
  4. zorinlynx thread starter macrumors 603

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #4
    It turned out something was seriously wrong with her phone; something got corrupted in either the OS or her data.

    The phone hung when attempting "Reset all settings" and wouldn't come back. iTunes was unable to restore the phone. DFU restore didn't work either the first time. After rebooting my Mac I was finally able to get the phone to DFU restore, then we were able to restore from her last iCloud backup on March 1st.

    I have no freaking idea what happened to her phone, but at least it's working again. I hate technology sometimes. :p
     

Share This Page