iPhone 5 Camera - Pink/Purple blocks, resets

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Add-Delay, Oct 28, 2012.

  1. Add-Delay macrumors newbie

    Add-Delay

    Joined:
    Oct 28, 2012
    Location:
    Adelaide, Australia
    #1
    I've noticed a very weird issue with the camera on my iPhone 5, and wondering if anyone else has experienced it. It seems different than other reports of lines across the screen.

    After a few seconds the camera freezes and a pink/purple block partially covers the screen. The camera then resets and the process is repeated over and over. A faint audible click is heard when it resets, from the camera mechanisms. The issue also occurs in 3rd party camera apps.

    As far as I can tell, it's only the rear-facing camera that is affected, haven't seen it happen on the front facing one so far.

    I've got a phone appointment booked with Apple for tomorrow, but not keen at all at the thought of having to send it in (since that would leave me phone-less. No official Apple stores here, so can't visit a genius bar in person).

    Video of it happening:
    http://www.youtube.com/watch?v=IOFwxLAqyf0
     
  2. Luno macrumors newbie

    Joined:
    Nov 1, 2012
    #2
    I just started experiencing the exact same problem. It's exactly as you describe. Were you able to get resolution?
     
  3. amnesia macrumors newbie

    Joined:
    Apr 30, 2004
    #3
    The latest 6.0.1 update mentions lines over the keyboard.
    I have the same issue with video and photos.

    I believe it's a software issue. Hope to God not hardware, I don't have an apple store in my country -_-
     
  4. Add-Delay thread starter macrumors newbie

    Add-Delay

    Joined:
    Oct 28, 2012
    Location:
    Adelaide, Australia
    #4
    Amnesia - similar, but mine is a different issue. I've seen shots of others with lines across the camera, but in my case it was large solid areas and the camera would freeze. It seems very much a hardware issue (the camera sensor would be my guess).

    Luno - I spoke with Apple, and after trying a few things like hosing all the settings, and then trying a full restore, they sent me out a replacement which arrived today (I'm just restoring from backup now).
     
  5. deej89 macrumors newbie

    deej89

    Joined:
    Sep 9, 2008
    Location:
    Atherton, Manchester, UK
    #5
    I had this from day 2, you can imagine my frustration.

    Finally got round to taking it to the Genius bar in December. Swapped it straight out for me, after looking really confused.

    Genius reported it as hardware fault. Nip it back to the Apple store and see what they say.

    My new one has also started doing it, it's locked up once or twice but so far it's not permanent like it was on my first one. Long as it's intermittent I can't really return it. I just hope it doesn't happen again *touches wood*.

    Good luck!
     

Share This Page