iPhone 5 cannot update apps

Discussion in 'iPhone' started by aaron5566, Feb 1, 2013.

  1. aaron5566 macrumors regular

    Jun 23, 2012
    Hey I'm a first time iPhone user and my phone is being weird nowadays. It says that I have an update and once I open my App Store to check the updates, it won't load anything. It's just a plain white page. Anyone experiencing this or have any clue on how to fix it? This is driving me nuts.
  2. kongchen macrumors newbie

    Feb 1, 2013
  3. aaron5566 thread starter macrumors regular

    Jun 23, 2012
    It doesn't work. :( tried restarting my phone too... Also tried to load the update page using 3G . Didn't work too.
  4. Fabricman112 macrumors regular


    Apr 3, 2010
    this has happened to me a few times.. if you sync apps with itunes, you can update the apps in itunes and sync the phone...

    last week on holiday a few apps got stuck on "installing", the internet wasn´t very good at the hotel so the updates were frozen.

    this would not be a problem if you could use the old version, but of course you cant :confused:

Share This Page